Different Rev on stack


Userlevel 1
I have a stack of x450e switches and I recently updated the XOS. When I do a Show Version it shows the two slots with different Rev #'s. Rev 10 is the correct version but slot 2 shows Rev 7. Also, the BootROM is different. Is that normal, and if not what do I need to do to correct this issue?

Slot-1 Extreme-Core.1 # show verSlot-1 : 800190-00-10 0748G-80067 Rev 10.0 BootROM: 1.0.5.7 IMG: 15.3.5. 2
Slot-2 : 800190-00-07 0814G-80299 Rev 7.0 BootROM: 1.0.3.5 IMG: 15.3.5.2
Slot-3 :
Slot-4 :
Slot-5 :
Slot-6 :
Slot-7 :
Slot-8 :

Image : ExtremeXOS version 15.3.5.2 v1535b2-patch1-10 by release-manager
on Fri Apr 8 11:48:36 EDT 2016
BootROM : 1.0.5.7
Diagnostics : 5.10

7 replies

Userlevel 5
Revision is the revision of the hardware and can't be changed.
Userlevel 6
Hello Andrew as Brad said that is the HW Rev number and that is normal to have different revs based on when the product was purchased. I do see that the boot rooms are different which is possible depending on the type of switches. If they are the same type then you may want to look at the need to upgrade them P
Userlevel 1
Paul Russo wrote:

Hello Andrew as Brad said that is the HW Rev number and that is normal to have different revs based on when the product was purchased. I do see that the boot rooms are different which is possible depending on the type of switches. If they are the same type then you may want to look at the need to upgrade them P

Yes, they are both the same type of switch and there are in a stack. Both x450e switches. Are you saying upgrade the hardware or XOS?
Userlevel 1
Thanks for the reply. So, the Rev # is normal, would that be true for the BootROM as well?

I also did a show slot detail and that all looks correct.

Slot-1 Extreme-Core.7 # show slot detail
Slot-1 information:
State: Operational
Download %: 100
Restart count: 0 (limit 5)
Serial number: 800190-00-10 0748G-80067
Hw Module Type: X450e-48p
SW Version: 15.3.5.2
SW Build: v1535b2-patch1-10
Configured Type: X450e-48p
Ports available: 50
Recovery Mode: Reset
Node MAC: 02:04:96:34:8F:84
Current State: MASTER
Image Selected: primary
Image Booted: primary
Primary ver: 15.3.5.2
Secondary ver: 15.3.5.2
Config Selected: primary.cfg

Slot-2 information:
State: Operational
Download %: 100
Restart count: 0 (limit 5)
Serial number: 800190-00-07 0814G-80299
Hw Module Type: X450e-48p
SW Version: 15.3.5.2
SW Build: v1535b2-patch1-10
Configured Type: X450e-48p
Ports available: 50
Recovery Mode: Reset
Node MAC: 02:04:96:34:8F:84
Current State: BACKUP (In Sync)
Image Selected: primary
Image Booted: primary
Primary ver: 15.3.5.2
Secondary ver: 15.3.5.2
Config Selected: primary.cfg
Userlevel 5
Generally we don't recommend a customer to upgrade or change the bootrom version unless there's a reason to do so. Is everything working normally?
Userlevel 1
Yes, everything is working normally, I was just concerned when I seen the difference and wanted to make sure that was all normal.

Thanks again for the quick response.
Userlevel 3
Hi Andrew,
BootROM 1.0.5.7, which is currently installed on slot 1 of the 2-node stack is the latest BootROM for the X450e switches. Since you have a 2-node stack of the same type, to avoid any unexpected side effects in case of a stack node failure/failover you can consider upgrading slot 2 to a matching BootROM as Slot 1, and then reboot Slot 2 for the BootROM update to take effect (ideally during a short maintenance window).
Thank you.

Best regards,
Andrew

Reply