Header Only - DO NOT REMOVE - Extreme Networks

Disabling CLI prompting also disables command history

  • 13 March 2019
  • 2 replies

When you disable CLI prompting in order to get rid of those pesky confirmation prompts, CLI stops recording new commands, and "dis cli p" remains the last command in your history until you just give up and type "en cli p".
I guess this is somewhat related to CLI prompting being a problem for scripts (hence the "disable cli prompting" command), and history not being used in scripts... *sigh*

Is this a known issue ? Is there any hope for a fix in upcoming releases ?

2 replies

Userlevel 7
Hi Nicolas,
What EXOS version are you seeing this on, and which command history is affected?
Is this the "up arrow" command history or the actual "history" command?
Hello Drew, thanks for your answer, and sorry about not being more specific.
The EXOS version I'm currently working on is, but I observed the same behavior on previous 16.1 and 16.2 releases.
Both the "up arrow" and the "history" command are affected.