Question

ELRP configuration x440

  • 18 April 2019
  • 2 replies
  • 338 views

Hello.

I'm new in Extreme and want to know more about ELRP configuration.

  1. I have some x440 swtches in network.
  2. Some switches can places nearly one to another.
  3. Users can create loop between access ports of two nearly switches.
  4. How to prevent this?
I have next simple scenario:


On sw-1 with loop on ports 1 and 5 which placed in one vlan, elrp work fine.
On sw-2 with loop on ports 1 and 20 which placed in different vlans, elrp does not work. How i must to configure elrp in this case?
And finally - how i must to configure ELRP on sw-1 and sw-2 to detect loop between access ports of switches, if they placed in different vlans on this switches.
Should i use vlan 30 (voice vlan) for this purposes, or maybe use only RSTP with edge and restrict settings for access ports?

ELRP config :
sw-1:
enable elrp-client
сonfigure elrp-client periodic VLAN_0010 ports 1-14 log disable-port egress permanent
сonfigure elrp-client periodic VLAN_0020 ports 15-50 log disable-port egress permanent

sw-2:
enable elrp-client
сonfigure elrp-client periodic VLAN_0010 ports 1-14 log disable-port egress permanent
сonfigure elrp-client periodic VLAN_0020 ports 15-50 log disable-port egress permanent


Please help.

2 replies

Userlevel 5
Given the scenario where the two ports are looped on separate VLANs, the ELRP packet is not coming back on either VLAN therefore a loop is not being detected. A workaround to this would be to create a dedicated ELRP VLAN with all ports added to it. This would lead to a loop being detected on the dedicate ELRP VLAN.

In the first scenario, with a loop connected to two ports in the same VLAN, the loop would be detected on the dedicated ELRP VLAN as well as the single VLAN where the ports are looped.
@Ty Izzet thank you for answer.
Yes i came to to this decision too.

I use vlan 30 (voice vlan for all my access ports) as elrp dedicated vlan.
My elrp configuration on access switches is next:
enable elrp-client
сonfigure elrp-client periodic VLAN_0030 ports 1-50 log disable-port egress permanent


  1. Disabled STP on access ports, because his priority of port blocking is higher then elrp.
  2. Enabled elrp on all access ports.
  3. Disabled elrp on uplink/downlink trunk ports.
I checked this configuration in loop scenarios above - everything work fine, as expected.

Reply