Question

Enable diffserv on all ports / Problems with Sharing

  • 7 July 2020
  • 4 replies
  • 141 views

Userlevel 3

Hello,

I need to enable diffserv examination on multiple XOS-switches on all ports. The problem is: There are multiple LAGs configured on each switch. When I execute “enable diffserv examination ports all” I get the typical error “2:10 is member of a load sharing group. Apply …. to the load share master port 2:8”

I would expect that the setting is then applied to all ports except for the load sharing members. But the setting isn’t set on any port, not even on the ports before 2:10.

Any idea how I can solve this? Don’t want to login to dozens of switches and enable this on every port that isn’t part of a LAG manually.

Or is this even a bug? Then I would open a support ticket.

Best regards

Stefan

 


4 replies

Userlevel 6
Badge

Hi Stefan,

 

I see. By now perhaps some scripting could be done to parse ‘show sharing’ and prepare list of ports and execute ‘enable diffserv examination’. But it’s a nice thing to place a feature request about, I totally agree. It would be helpful to have just a warning on that (like with moving ports between VLANs as untagged ports).

 

Kind regards,

Tomasz

Userlevel 3

Hello,

scripting is always a solution, hehe. :-)

When I find some spare time I will open up a ticket at GTAC and place the feature request.

Thank you for your input!

Best regards
Stefan

Userlevel 6
Badge

Hi Stefan,

 

What if you tried to ‘enable diffserv examination ports 2:1-2:8,2:11-18,2:21-2:24’.. etc., so that for LAGs only master port is covered with the command?

 

Hope that helps,

Tomasz

Userlevel 3

Hi Tomasz,

that works fine and I already did this for the first two switches. The problem is: I would have to check for every switch which ports are members of a LAG. With 40 switches on the main campus (some of them are stacks with 6 members) and multiple LAGs per Switch (Switch-Uplink, Access-Point Downlink and so on…) this would be a very time consuming task. :-)

I had in mind that for such commands the CLI would print the error mentioned above, but would still execute the command for all the other ports. But maybe I’m wrong…

Best regards
Stefan

Reply