Enable SummitStack-V on single switch?


Userlevel 4
In the past, our best practice was to enable stacking on everything (including single switches), allowing for future additions to the switch without having to suffer an outage and reconfiguration. It seems that when using 10Gb stacking on a 460-G2, unless you boot with a connected "secondary" switch, the enable stacking command has no impact and the switch refuses to enter stacking mode by itself. Can anyone confirm this behavior? Any suggestions to accommodate the expansion without reboot scenario?

Thanks,
Eric

6 replies

This could be code related.

We have several X460-G2s deployed as single switch stacks using the alternate front ports.
Userlevel 5
What EXOS version are you running?

I did a quick test in my lab and don't see this, i.e. I am able to enable stacking on a single node:

* Slot-1 Stack.1 # sh slot
Slots Type Configured State Ports
--------------------------------------------------------------------
Slot-1 X460G2-48x-10G4 Operational 54
Slot-2 Empty 0
Slot-3 Empty 0
Slot-4 Empty 0
Slot-5 Empty 0
Slot-6 Empty 0
Slot-7 Empty 0
Slot-8 Empty 0

* Slot-1 Stack.2 # sh stacking-support

Stack Available Ports
Port Native Alternate Configured Current
----- ----------------- ---------- ----------
1 Yes 51 * Alternate Alternate
2 Yes 52 * Alternate Alternate
stacking-support: Enabled Enabled

Flags: * - Current stack port selection

* Slot-1 Stack.3 # sh stacking
Stack Topology is a Daisy-Chain
Active Topology is a Daisy-Chain
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:9b:c2:0f 1 Active Master CA-
* - Indicates this node
Flags: (C) Candidate for this active topology, (A) Active Node
(O) node may be in Other active topology
* Slot-1 Stack.4 #
Userlevel 4
Running the recommended 21.1.5.2 build. If I show stacking-support, it says enabled but the port references from a configuration standpoint don't seem to use the switch:port commands (just port). Again, nothing is connected to the back stacking ports (27/28). In SummitStack if you enabled stacking on a single switch, the port commands would reference switch:port just like a multi-switch stack.
Even if stacking is enabled you still need to configure staging to trigger the reboot and create the stack. It sounds like you are short a command or two.
Userlevel 3
Have you run the "enable stacking" after "you configure stacking .... " ?

Also just for everyone information, SummitStack-V do support SFP+ BiDi as show below.

This can saves up on your precious FO core asset.

Userlevel 4
Boy do I feel dumb... 🙂 So used to stacking on SummitStack that I missed a step on the 10GB stacking (easy-setup). While I configured and enabled stacking - it seems that without this command at the end I was not really done. Thanks for the quick responses!
Userlevel 5
This is likely due to the stack-port selection being native instead of alternate:
# configure stacking-support stack-ports all selection alternate[/code]https://documentation.extremenetworks.com/exos_commands_16/exos_16_2/exos_commands_all/r_configure-s...

Reply