Header Only - DO NOT REMOVE - Extreme Networks

exos vm gns3 and virl


how to get it working properly...

i have been attempting a number of different ways to implement the 16.1.2 vm in both gns3 and virl...

i have the most success at the command line with qemu

here is the procedure whereby i can get it to boot in a window at the cmd line:

make an image container

sudo qemu-img create -f qcow2 /var/lib/libvirt/images/exos_cmd.img 3G

add x86 config commands

sudo qemu-system-x86_64 -m 1024 -hda /var/lib/libvirt/images/exos_cmd.img -cdrom /home/ccie/images/ios/exospc-16.1.2.14.iso -boot d

and this final command will get me to a login:

sudo qemu-system-x86_64 -hda exos.img -cpu core2duo

i have been attempting a combination of virsh and virt-manager with little success... seems the hang up is with -cpu core2duo support in virt-manager. see my xml below:


exos_cmd
[u]b498fc1a-f3b0-9f06-2e46-0c4ba186dd3c
1048576
1048576
1

/machine


hvm
[b]
[b]







destroy
destroy
destroy

[i]/usr/bin/kvm-spice


























[i]

















[i]
[i]



1 reply

Userlevel 6
Brian,

Please download one of these qcow2 images to use with qemu:
- v16.1.1.4: https://www.dropbox.com/s/0vkzfy3wgt3o7hb/EXOS-VM_v16.1.1.4-disk1.qcow2?dl=0
- v21.1.1.4: https://www.dropbox.com/s/9w5mh58uchoug6y/EXOS-VM_v21.1.1.4-disk1.qcow2?dl=0

Using those I created qemu VM's in GNS3 an the cli used by GNS3 is:

/usr/bin/qemu-system-i386 -name EXOS VM 21.1.1.4-1 -m 256M -smp cpus=1 -enable-kvm -boot order=c -drive file=/opt/gns3/projects/b1e4d40d-aac5-4f29-9637-2511dce36db4/project-files/qemu/a59c2f3f-1079-4a1a-9821-d26d4c87fda4/hda_disk.qcow2,if=ide,index=0,media=disk -serial telnet:0.0.0.0:2015,server,nowait -monitor tcp:127.0.0.1:40457,server,nowait -net none -device rtl8139,mac=00:00:ab:fd:a4:00 -device rtl8139,mac=00:00:ab:fd:a4:01 -device rtl8139,mac=00:00:ab:fd:a4:02 -device rtl8139,mac=00:00:ab:fd:a4:03 -device rtl8139,mac=00:00:ab:fd:a4:04 -device rtl8139,mac=00:00:ab:fd:a4:05 -device rtl8139,mac=00:00:ab:fd:a4:06 -device rtl8139,mac=00:00:ab:fd:a4:07 -device rtl8139,mac=00:00:ab:fd:a4:08 -device rtl8139,mac=00:00:ab:fd:a4:09 -device rtl8139,mac=00:00:ab:fd:a4:0a -device rtl8139,mac=00:00:ab:fd:a4:0b -device rtl8139,mac=00:00:ab:fd:a4:0c -nographic -cpu core2duo -nographic

Where it says
file=/opt/gns3/projects/b1e4d40d-aac5-4f29-9637-2511dce36db4/project-files/qemu/dfd80978-3796-4994-a8ce-9fd8845ba21e/hda_disk.qcow2
you should replace that with one of the two qcow2 images I've pointed you to. In this case, it was the v21.1.1.4.qcow2 image.

I guess you can drop all the -netdev entries, unless you want to specify the mac addresses of the different ports

I hope this helps you.



Reply