Header Only - DO NOT REMOVE - Extreme Networks
Question

Firmware Update X440-G2-12p failure

  • 4 June 2020
  • 7 replies
  • 202 views

Hi, there!

I have got a problem with two X440-G2-12p. They are working both with firmware 30.2.2.17 and i can’t take them to a higher firmware. I’ve tried 30.4.1.2, 30.5.1.15v and 30.6.1.11-patch1-11. Both switches are downloading the new firmware and they are beginning to install it, but then i get Error like these:

Error: Failed to install image - Unable to create persistent partition /dev/mmcblk0p10  Rescue using EXOS 30.2 or later

Failed to install image - /dev/mmcblk0p9 (data) partition not found on /dev/mmcblk0.  Rescue using EXOS 30.2 or later

 

On the other hand i’ve some other switches of the same type and they get the latest firmware without any problems.

What can i do to fix these both switches?

 

Thank you for your statements!

Carsten


7 replies

Userlevel 4

Hi Carsten,

 

Please check the following article for a solution.

https://gtacknowledge.extremenetworks.com/articles/Solution/000045944 

 

Best Regards,

Nikolay

Hi, Nikolay!

Thank you for your reply. I#ve tried it befor withe the version 30.2.2.17. I installed in in both partitions and rebootet from each of it. But the error left. Now i will try it with version 30.2.2.8.

Two of these switches are running withe the solution with 30.2.2.17 as e step betwenn, but a third one is not running with it. I will see, if it will works with 30.2.2.8. It is really frustrating.

 

Best regards

Carsten

It didn’t work with the 30.2.2.8 :-(

 

Any other idea?

Userlevel 4

Hi Carsten,

Just upgrade switch from Bootrom, it will solve the issue.

Best Regards,

Nikolay 

Hi, Nicolay!

Thank our for your reply, but i don’t understand, what that means. How can i upgrade from “Bootrom”? What do I have to do?

Best regards,

Carsten

Userlevel 4

Hi Carsten,

Please follow instructions from the article - https://gtacknowledge.extremenetworks.com/articles/How_To/How-To-install-EXOS-Image-via-BootROM-on-G2-platform-switches/?q=Bootrom&l=en_US&fs=Search&pn=1

Best Regards,

Nikolay

I am getting the same error with 4 X440-G2-48p-10GE. I will try upgrading to version 30.2.1.8 to both partitions. 

Reply