How to create LAG between two X670 switches using VIM4 ports?


How do I create a LAG (lacp layer 2) between a pair of X670 switches using the VIM4 module ports? I can create one using a pair of ordinary 10G ports on the front panel and it works as shown in the manuals, but I cannot get the thing to work when attempting to use 2 of the VIM4 module ports to interconnect the two switches.

Please don't suggest creating a stack... been there, tried that, and the stacking behavior failed in an unacceptable way. All I want is a simple high-bandwidth uplink between the two switches, and if I could group two 40G VIM4 ports together in a LAG between them that would ideal for me.

I don't know if I'm addressing the ports wrong or not. My understanding thus far is that the VIM physical port to logical port (as used in the configs) numbers goes something like this:

VIM Port 1 - Ports 49, 50, 51, 52

VIM Port 2 - Ports 53, 54, 55, 56

VIM Port 3 - Ports 57, 58, 59, 60

VIM Port 4 - Ports 61, 62, 63, 64

It is my understanding that if the VIM ports are partitioned as 1x40G and I want to use VIM Ports 3 and 4 on both switches to form the LAG lacp link between them, I'd use the first logical port number in each group (i.e. 57 and 61) like this:

#enable sharing 57 grouping 57,61 algorithm address-based L2 lacp

That apparently creates the LAG but when connecting the two switches together using the QSFP+ cables, the link never comes up.

Any ideas?

5 replies

Userlevel 6
Hey Neal

I don't believe there is anything special about those ports and creating them into a LAG.

A few questions is the switch and those ports in default configuration? It sounds like you had them stacked before?

Do you see the ports when you do a show ports all?

When you execute the enable sharing command it doesn't sound like it errors out and when you do a show sharing it shows the LAG as being created correct?

Thanks
P
Way back many months ago, I did try a stack configuration, but returned the switches to stock default before reconfiguring them as standalones. (disable stacking, unconfigure switch all)

I had been running a LAG between the two, made with a pair of 10G ports on the front of each unit and that was working well, so I decided to try fixing what wasn't broke and attempt to create a LAG with two of the 40G ports on the back of each switch 🙂

Here's a "show ports 49-64 configuration", but it says "NP" (Port Not Present) in the Link State column:

--------

# sh ports 49-64 configuration no-refresh
Port Configuration
Port Virtual Port Link Auto Speed Duplex Flow Load Media
router State State Neg Cfg Actual Cfg Actual Cntrl Master Pri Red
================================================================================
49 VR-Default E R OFF 40000 FULL NONE
50 VR-Default E NP OFF 10000 FULL NONE
51 VR-Default E NP OFF 10000 FULL NONE
52 VR-Default E NP OFF 10000 FULL NONE
53 VR-Default E R OFF 40000 FULL NONE
54 VR-Default E NP OFF 10000 FULL NONE
55 VR-Default E NP OFF 10000 FULL NONE
56 VR-Default E NP OFF 10000 FULL NONE
57 VR-Default E NP OFF 40000 FULL 57 Q+CR4_.5
58 VR-Default E NP OFF 10000 FULL NONE
59 VR-Default E NP OFF 10000 FULL NONE
60 VR-Default E NP OFF 10000 FULL NONE
61 VR-Default E NP OFF 40000 FULL 57 Q+CR4_.5
62 VR-Default E NP OFF 10000 FULL NONE
63 VR-Default E NP OFF 10000 FULL NONE
64 VR-Default E NP OFF 10000 FULL NONE
================================================================================
> indicates Port Display Name truncated past 8 characters
Link State: A-Active, R-Ready, NP-Port Not Present, L-Loopback
Port State: D-Disabled,E-Enabled, Media: %-Licensed, !-Unsupported, $-Restricted
Media Red: * - use "show port info detail" for redundant media type
Flow Cntrl: Shows link partner's abilities. NONE if Auto Neg is OFF

------------------------------

Here's a "show sharing detail", again with "NP on both links:

# show sharing detail
Load Sharing Monitor
Config Current Agg Ld Share Ld Share Agg Link Link Up
Master Master Control Algorithm Group Mbr State Transitions
==============================================================================
57 LACP L2 57 - NP 0
L2 61 - NP 0
==============================================================================
VLAN Configuration:
Name: Default, Virtual Router: VR-Default
Internal tag = 1, MAC-limit = No-limit
STP Configuration:
s0(disable), Tag= (none), Mode=802.1D, State=FORWARDING
==============================================================================
==============================================================================
Link State: A-Active, D-Disabled, R-Ready, NP-Port not present, L-Loopback
Load Sharing Algorithm: (L2) Layer 2 address based, (L3) Layer 3 address based
(L3_L4) Layer 3 address and Layer 4 port based
(custom) User-selected address-based configuration
Custom Algorithm Configuration: ipv4 L3-and-L4, xor
Number of load sharing trunks: 1

--------------
Userlevel 7
Hi Neal,
When working with 40G ports, there's an option to "partition" them into 4x10G ports, rather than 1x40G port. The "NP" ports are port numbers reserved for the 10G ports.
So with 40G ports, even though they appear consecutive on the switch, they're numbered in software as 49, 53, 57, 61. If they're partitioned as 10G ports, they're consecutively numbered in software.

Here's the command for doing this:
code:
configure ports [port_list | all] partition [4x10G | 1x40G]

And some documentation.

Hope this helps! Maybe I answered a question you didn't ask 🙂

-Drew
# configure ports 57 partition 1x40G
Port 57 does not support Port Partitioning mode 1x40G

# configure ports 61 partition 1x40G
Port 61 does not support Port Partitioning mode 1x40G

But the command worked for ports 49 and 53 so I moved my LAG to those two and now it comes up and works normally (showing 40G bandwidth each).

Any clues on what's up with the VIM sockets 3 and 4? -- ports 57 (thru 60) and 61 (thru 64) ?????
Userlevel 7
Hi,

what about:
- show stacking stack-port
- show stacking configuration

I believe you need to do 'unconfigure stacking-support' as well to have the ports back to data port and not stack port.

Reply