How to delete part of an OSPF command in the Config


I have a couple lines in my OSPF config that i cant seem to remove.

i am trying to get rid of this:

configure ospf vlan VLAN_0009 priority 0

i have tried "unconfigure" command which doesnt work.

not sure what else to use.

12 replies

Userlevel 3
configure ospf delete vlan xxxx
Userlevel 6
Hello Sentenced,

What version of code are you running on? Is this command causing an issue? The command by itself should be harmless.
i am on Version 21.1.2.14.

it is not causing any issues it is just annoying seeing it in there and not being able to delete it.

the command that stephen stated does not delete the line.
Userlevel 6
Hello Sentenced,

I replicated this and was able to remove this output with the following:

"unconfigure ospf vlan "
Patrick, i have tried that as well and it still doesnt remove it for me.

X670G2-48x-4q.17 # show config ospf#
# Module ospf configuration.
#
configure ospf routerid 1.1.1.1
enable ospf
configure ospf vlan VLAN_0007 priority 0
configure ospf vlan VLAN_2050 priority 0
configure ospf vlan VLAN_900 priority 0
X670G2-48x-4q.18 # unconfigure ospf vlan VLAN_900
* X670G2-48x-4q.19 # show config ospf
#
# Module ospf configuration.
#
configure ospf routerid 1.1.1.1
enable ospf
configure ospf vlan VLAN_0007 priority 0
configure ospf vlan VLAN_2050 priority 0
configure ospf vlan VLAN_900 priority 0
* X670G2-48x-4q.20 #
Userlevel 6
Hello Sentenced,

I am getting a different output:

* X460G2-24x-10G4.45 # show config ospf
#
# Module ospf configuration.
#
configure ospf routerid 1.1.1.1
enable ospf
configure ospf vlan VLAN_0007 priority 0
configure ospf vlan VLAN_2050 priority 0
configure ospf vlan VLAN_900 priority 0
* X460G2-24x-10G4.46 # unconfigure ospf vlan "VLAN_900"
* X460G2-24x-10G4.47 # show config ospf
#
# Module ospf configuration.
#
configure ospf routerid 1.1.1.1
enable ospf
configure ospf vlan VLAN_0007 priority 0
configure ospf vlan VLAN_2050 priority 0
* X460G2-24x-10G4.48 #

Are you running on a specific patch of 21.1.2.14? The hardware should not make a difference but I will see if I can do this on a x670g2.
Hey Patrick, dont think i am on anything specific. here is the "show version" from my X670.

* X670G2-48x-4q.35 # show versionSwitch : 800546-00-08 [serial removed] Rev 8.0 BootROM: 1.0.2.1 IMG: 21.1.2.14
PSU-1 : Internal PSU-1 800462-00-07 1604W-80105
PSU-2 : Internal PSU-2

Image : ExtremeXOS version 21.1.2.14 by release-manager
on Fri Aug 26 12:49:31 EDT 2016
BootROM : 1.0.2.1
Diagnostics : 5.4
* X670G2-48x-4q.36 #
Userlevel 6
It is possible the switch is running on a non-patched version. The show version won't show this though. Would you mind pasting the "show switch" ouput? This will have more information.
* X670G2-48x-4q.36 # show switch

SysName: X670G2-48x-4q
SysLocation:
SysContact: support@extremenetworks.com, +1 888 257 3000
System MAC: 00:04:96:9B:04:60
System Type: X670G2-48x-4q

SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled

Current Time: Tue Feb 28 19:14:45 2017
Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time: Tue Feb 28 16:43:42 2017
Boot Count: 21
Next Reboot: None scheduled
System UpTime: 2 hours 31 minutes 2 seconds

Current State: OPERATIONAL
Image Selected: primary
Image Booted: primary
Primary ver: 21.1.2.14
Secondary ver: 16.1.1.4

Config Selected: primary.cfg
Config Booted: primary.cfg

primary.cfg Created by ExtremeXOS version 21.1.2.14
392380 bytes saved on Tue Feb 28 18:17:50 2017
* X670G2-48x-4q.37 #
Userlevel 7
Hi,

if you are on Advanced Edge license, this is normal to have a priority of 0, and you can't change that. Core license needed to configure priority.
Hello Grosjean,

we are running on the advanced edge license. Is there are reason why deleting the priority commands is not an option?

Thank you for the information.
Userlevel 7
Hi,

That's a restriction coming from Adv Edge license, this is meant to be like that. This is what we call OSPF-Edge: priority forced to 0 and up to 4 neighbors.

This config is forced and you can't remove it. If you want to be able to configure priority, you'll need to upgrade to Core license. Note that using p2p type links, you don't care about priority.

Reply