How to disable ntp in ExtremeXOS.


how to disable ntp in ExtremeXOS?
I tried some commands as "disable ntp" but many times it through this error: %% Invalid input detected at '^' marker.
Help me, please.
Thanks.

16 replies

Userlevel 7
command refernce guide...

configure ntp [server | peer] delete [ip_address | host_name]
Hi,
I tried as "configure ntp server delete XX.XXX.XXX.XX" it throwed same error.
"%% Invalid input detected at '^' marker."
Userlevel 7
Could you please post the output for "show configuration ntp"

Thx
Unfortunately same error 😞

# show configuration ntp ^
%% Invalid input detected at '^' marker.
Userlevel 3
Taner,

What model switch and version of EXOS is this?
Hi Kevin,

Switch : 800302-00-01 1213G-81070 Rev 1.0 BootROM: 1.0.3.5 IMG: 12.6.2.10 XGM2-1 :
Image : ExtremeXOS version 12.6.2.10 v1262b10 by release-manager
on Thu Sep 29 18:17:34 EDT 2011
BootROM : 1.0.3.5
Userlevel 4
Taner,

images older than 15.5 require the NTP xmod in order to obtain the NTP feature. Is the NTP xmod installed on the Summit X450a in question? The "show version images" can be used to confirm the install images.

-Andrew
Userlevel 3
Taner,

Please update the following output.

sh version image
sh process ntp

You need to disable SNTP in order to work NTP.
SNTP and NTP cannot run together.

Need to Install NTP module to switch for 15.x.x.x
install image "summitX-15.3.3.5-patch1-6-ntp.xmod"
run update

-Paul

FYI. Thanks.
https://community.extremenetworks.com/extreme/topics/can-the-bd8810-be-used-as-a-ntp-server
Hello Andrew,

This is images version:

Card Partition Installation Date Version Name Branch------------------------------------------------------------------------------
Switch primary Mon Nov 5 13:27:25 UTC 2012 12.6.2.10 summitX-12.6.2.10.xos v1262b10
Switch primary Mon Nov 5 13:45:43 UTC 2012 12.6.2.10 summitX-12.6.2.10-ssh.xmod v1262b10
Switch secondary Mon Nov 5 13:18:14 UTC 2012 12.6.2.10 summitX-12.6.2.10.xos v1262b10
Switch secondary Mon Nov 5 13:44:42 UTC 2012 12.6.2.10 summitX-12.6.2.10-ssh.xmod v1262b10
Hi Paul,

When I write "sh process ntp" command I get same error again.
^
%% Invalid input detected at '^' marker.
---------------------------------------------------------------------------------
How to disable ntp after install image?
Userlevel 7
Hi Taner,
NTP wasn't available until EXOS 12.7 and required a separate XMOD until EXOS 15.5. Since your switch is on 12.6, NTP isn't available.
Hi Drew,

Thank you. Then I need to upgrade to EXOS 15.5.
This commands are enough?
install image "summitX-15.3.3.5-patch1-6-ntp.xmod"
run update
Userlevel 4
Taner Yamak wrote:

Hi Drew,

Thank you. Then I need to upgrade to EXOS 15.5.
This commands are enough?
install image "summitX-15.3.3.5-patch1-6-ntp.xmod"
run update

Taner,

If you are upgrading to EXOS 15.5 the NTP can be configured without the "run update" command or a separate ntp.xmod image.

If you are upgrading to EXOS 15.3 the commands mentioned are correct.

-Andrew
Hi Drew,

My aim is disabling ntp due to working for is leap section. If my system is EXOS 12.6 hasn't ntp so I do not need to disable ntp, isn't it?
Userlevel 4
Taner Yamak wrote:

Hi Drew,

My aim is disabling ntp due to working for is leap section. If my system is EXOS 12.6 hasn't ntp so I do not need to disable ntp, isn't it?

Taner,

Correct; as NTP is not an available feature in EXOS 12.6 there is no need to disable NTP.

-Andrew
Userlevel 6
Helpful GTACKnowledge articles regarding NTP configuration and operation in EXOS:
How to Configure NTP on EXOS switch?
Where do I download the NTP xmod for EXOS 15.5 or later?
Is the ntp.xmod mandatory to enable NTP server in EXOS?
Unable to configure NTP on Summit X430

Reply