How to do Stacking Role from NONE to Backup


Userlevel 3
How to do Stacking Role from NONE to Backup
---------------------------------------------------------------

X250e-48p and x250e-48t Stacking. I want to achieve Master and Backup Stack Topology. Please advice me how to configure it. Thanks.



Slot-1 Stack.1 # show stackingStack Topology is a Ring
Active Topology is a Ring
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:28:22:1b 1 Active Master CA-
00:04:96:26:64:a9 2 Active CA-
* - Indicates this node
Flags: (C) Candidate for this active topology, (A) Active Node
(O) node may be in Other active topology
Slot-1 Stack.2 #

Slot-1 Stack.2 # sh stack configurationStack MAC in use: 02:04:96:28:22:1b
Node Slot Alternate Alternate
MAC Address Cfg Cur Prio Mgmt IP / Mask Gateway Flags Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:28:22:1b 1 1 100 CcEeMm--- Ee
00:04:96:26:64:a9 2 2 50 CcEeMm--- Ee
* - Indicates this node

Slot-1 Stack.5 # sh stack stack-ports
Stack Topology is a Ring
Slot Port Select Node MAC Address Port State Flags Speed
---- ---- ------ ----------------- ----------- ----- -----
*1 1 Native 00:04:96:28:22:1b Operational C- 10G
*1 2 Native 00:04:96:28:22:1b Operational CB 10G
2 1 Native 00:04:96:26:64:a9 Operational CB 10G
2 2 Native 00:04:96:26:64:a9 Operational C- 10G
* - Indicates this node
Flags: (C) Control path is active, (B) Port is Blocked
Slot-1 Stack.5 #

- Paul

17 replies

Userlevel 7
Hi Paul,

The role coming up as none could me a couple different things. Moving forward I would recommend looking at the logs to see if it tells you why or use the "show slot" output. It could be a license or image mismatch. If you would like to post these outputs for evaluation I would be happy to take a look.
Userlevel 3
Patrick Voss wrote:

Hi Paul,

The role coming up as none could me a couple different things. Moving forward I would recommend looking at the logs to see if it tells you why or use the "show slot" output. It could be a license or image mismatch. If you would like to post these outputs for evaluation I would be happy to take a look.

Thanks Patrick,

Slot-1 Stack.4 # show slot
Slots Type Configured State Ports
--------------------------------------------------------------------
Slot-1 X250e-48p X250e-48p Operational 50
Slot-2 X250e-48t X250e-48t Failed 50
Slot-3 Empty 0
Slot-4 Empty 0
Slot-5 Empty 0
Slot-6 Empty 0
Slot-7 Empty 0
Slot-8 Empty 0

Slot-1 Stack.4 #
Userlevel 6
I think the 2nd slot has master-capability turned off so it cannot be backup or master.
Refer to the documentation to enable master-capability of slot 2.
http://documentation.extremenetworks.com/exos/EXOS_All/Stacking/t_configure-mastercapability.shtml

  • configure stacking slot 2 master-capability on
  • Then reboot slot 2.
Userlevel 3
OscarK wrote:

I think the 2nd slot has master-capability turned off so it cannot be backup or master.
Refer to the documentation to enable master-capability of slot 2.
http://documentation.extremenetworks.com/exos/EXOS_All/Stacking/t_configure-mastercapability.shtml

  • configure stacking slot 2 master-capability on
  • Then reboot slot 2.

Hi OscarK,

I have enabled the master-capability on slot 2. Thanks.

Slot number : 2
Stack state : Active
Master capable? : Yes
Stacking protocol : Standard
License level restriction : Edge
Userlevel 2
Paul,

All nodes in a stack must have matching image versions on the same matching partition. Example: If you are running 15.3.4.6-patch1-5.xos on your primary partition on slot 1, you must have the same version on the same partition on slot 2.

This is how we configure our stacks:

Master Stack:

--------------------------------------------------------------

enable stacking node-address



conf stacking node-address slot-number 1

conf stacking node-address master-capability on

conf stacking node-address priority 70



conf stacking node-address mac-address

conf slot 1 module

save

reboot node-address

Backup Stack: Master Capable

--------------------------------------------------------------

enable stacking node-address [b]



conf stacking node-address [b] slot-number 2

conf stacking node-address [b] master-capability on

conf stacking node-address [b] priority 60

conf slot 2 module

save

reboot node-address [b]

synchronize stacking node-address [b]

Patrick, please correct this if I am wrong in any way.

Thanks and good luck,
Stan
Userlevel 3
Stanley Riley Jr. wrote:

Paul,

All nodes in a stack must have matching image versions on the same matching partition. Example: If you are running 15.3.4.6-patch1-5.xos on your primary partition on slot 1, you must have the same version on the same partition on slot 2.

This is how we configure our stacks:

Master Stack:

--------------------------------------------------------------

enable stacking node-address



conf stacking node-address slot-number 1

conf stacking node-address master-capability on

conf stacking node-address priority 70



conf stacking node-address mac-address

conf slot 1 module

save

reboot node-address

Backup Stack: Master Capable

--------------------------------------------------------------

enable stacking node-address [b]



conf stacking node-address [b] slot-number 2

conf stacking node-address [b] master-capability on

conf stacking node-address [b] priority 60

conf slot 2 module

save

reboot node-address [b]

synchronize stacking node-address [b]

Patrick, please correct this if I am wrong in any way.

Thanks and good luck,
Stan

Hi Stan,

I use the same version, same partition and enable the master-capability yes. Thanks.
Userlevel 7
That looks right assuming all these commands were entered on only one switch. Try running the "synchronize stacking" command and reboot the stack. After the reboot give it a couple minutes to sync up and see if slot 2 has a role.
Userlevel 3
Hi Patrick,

I run the sh slot 2 and found out that it is because of License Mismatch.
Slot 1 is Edge and Slot 2 is Trial.
But any way how can i test this work.

Does it make sense? if i use this debug command in Slot 1 and make it as same license.
My current slot 1 license will be removed?

I used debug epm... command to Slot 2.
debug epm enable trial-license # hidden command to enable license for 30 days trial

Current State: FAIL (License Mismatch)
Slot-1 Stack.6 # sh slot 2
Slot-2 information:
State: Failed
Download %: 0
Last Error: License Mismatch
Restart count: 1 (limit 5)
Serial number: N/A(0) N/A(0)
Hw Module Type: X250e-48t
Configured Type: X250e-48t
Ports available: 50
Recovery Mode: Reset
Node MAC: 00:00:00:00:00:00
Current State: FAIL (License Mismatch)
Image Selected:
Image Booted:
Primary ver:
Secondary ver:
Config Selected: NONE

------------------------------------------------------------------------

Slot-1 Stack.7 # sh license
Enabled License Level:
Edge
Enabled Feature Packs:
None
Effective License Level:
Edge
Slot-1 Stack.8 #
------------------------------------------------------------------------
* Slot-2 Stack.4 # sh licenses
Enabled License Level:
30 days Trial - expires in 29 days
Effective License Level:
Trial
* Slot-2 Stack.5 #
Userlevel 7
You will need to run the "debug epm clear trial-license" command and then reboot in order for it be removed. This should resolve your issue assuming slot 2 has the same default license. Trial-license should not be run on a stack or on any switch that is going to be put into production.
Userlevel 3
Thanks Patrick,

Now my issue have been resolved by your informative advice.
I do thank you for your prompt response.

Slot-1 Stack.18 # sh stacking
Stack Topology is a Ring
Active Topology is a Ring
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:28:22:1b 1 Active Master CA-
00:04:96:26:64:a9 2 Active Backup CA-

- Paul
Userlevel 7
Hi Paul,

I have created an article on how to troubleshoot a failed or role-less node in a stack:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-troubleshoot-a-failed-node-or-a-node-without-a-role-in-a-stack

Please let me know if you feel like this will help in the future. Any feedback is welcome as well. I can update this article at anytime.
Hi Patrick,

This article is very useful. Thank you for your time and effort.

-Paul
Userlevel 3
Hi Patrick,

This article is very useful. Thank you for your time and effort.

-Paul
Userlevel 3
Hi all,

I will keep on update here. don't want to create another post. Since it's related to this stacking.

My question is How Can I Add Different Module to the current configured Module. Please see below for more detail.

I have uploaded the configuration to the Stack.
Current Configuration for Slot 1 is X250e-48t
and Now Replacement unit module is X250e-48p

if i use unconfigure slot 1.
Configuration will wipe out slot 1 config. i don't want to do it.

Please advice. How can i achieve without effecting the current config for port and vlan for slot 1 except changing from X250e-48t to X250e-48p. Thanks.

Slot-2 SW # unconfigure slot 1
This slot will be rebooted as part of this operation.

This will remove all port and vlan information for ports in this slot(1).
Any ports on this slot that are members of load share groups will be removed
from the load share group.
Continue ? (y/N)

configure slot 1 module X250e-48t
configure sys-recovery-level slot 1 reset
configure slot 2 module X250e-48t
configure sys-recovery-level slot 2 reset

Slot-2 SW # sh slotSlots Type Configured State Ports
-------------------------------------------------------------------------------------------------------------
Slot-1 X250e-48p X250e-48t Mismatch 50
Slot-2 X250e-48t X250e-48t Operational 50

Slot-2 SW # sh slot 1
Slot-1 information:
State: Mismatch
Download %: 0
Last Error: Card Mismatch
Restart count: 0 (limit 5)
Serial number: N/A(0) N/A(0)
Hw Module Type: X250e-48p
Configured Type: X250e-48t
Ports available: 50
Recovery Mode: Reset
Node MAC: 02:04:96:28:22:1B
Current State: FAIL (Card Mismatch)
Image Selected: secondary
Image Booted: secondary
Primary ver: 15.3.3.5
Secondary ver: 15.3.3.5
Config Selected: primary.cfg

Slot-2 SW #
Userlevel 6
From my knowlegde unconfigure slot 1 and reconfigure the ports and vlans on it is the only option to replace a slot with a different slot.
Userlevel 3
Hi OscarK,

It means i have to reconfigure the current configuration in order to replace different module in Stacking. 😞
Userlevel 6
Yes, but only for slot 1, all vlans still exist, as is other configuration, only port assignment and port specific configuration actions need to be done.

Reply