Header Only - DO NOT REMOVE - Extreme Networks
Question

How to install LegacyCLI-MOD


I am planning to install the LegacyCLI-MOD onto switches comfigured in a stack (2x X440, and 2x X450).

I have backed up the config on the primary/master switch to a tftp server. Is there any other backup methods suggested, other than backing up the .cfg file?

I have the quick reference guide that shows how to download the and install the .xmod via tftp. Is there another method?

Once installed, what should I do if I want to run Cisco commands by default?

Thanks in advance,
-Theo

15 replies

Userlevel 6
Hello Theo

There is noting more to backup the config that you need to do. Install the xmod like a normal image to the same location as the main image Primary for example. The main image and the xmod version must match.

once installed and running you can configure the cli style using the command configure cli style legacy permanent. the permanent keyword will mean all futures sessions will use the legacy CLI option

Hope that helps

P
Userlevel 4
There are two ways to take the config backup
1) tftp put
2) Upload configuration

first command will save the configarion in cfg file i.e XML file, which is not readable. Seconds command will save the configuration in XSF format which can be readable.

download image command is the best and only way to download the image.
Paul,

To verify my version I run the "show version" command, correct? This will then list my XOS version which I compare to my MOD? I believe they match exactly, I want to just verify my workflow.

Thanks,
-Theo
Sumit,

After I have downloaded the .cfg file using the "tftp put" command, how do I compare it to my "running config". I used the "show configuration" command, and I believe they are exact. Is this the correct comparison?
Userlevel 6
Yes the show version is the correct command. Yes in regards to the .cfg

P
Userlevel 4
Yes.
I have downloaded the .xmod to the switch stack, but chose not to install it at this time because I want to install during non-business hours. I cannot locate the image file downloaded to the below location. I used the command, along with the and no such luck.

vr "VR-Default" primary

Full output:

* Slot-3 Travis-MDF-440.1 # download image 10.179.179.137 summitX-15.3.2.11-LegacyCLI.xmod vr "VR-Default" primary
Do you want to install image after downloading? (y - yes, n - no, - cancel) No

Downloading to Slot-3(Master): ..
Downloading to Slot-2(Standby):
Downloading to Slot-1(Standby):
Downloading to Slot-4(Backup): .*.Image downloaded successfully
Userlevel 4
* X460-48p.3 # download image 10.67.51.99 summitX-15.5.1.6-LegacyCLI.xmod VR "VR-Mgmt"
Debug information files are present in internal-memory.
These files will be removed if you continue with download.
Do you want to continue with download and remove existing files from internal-memory? (y/N) Yes
Do you want to install image after downloading? (y - yes, n - no, - cancel) No

Downloading to Switch...
Image downloaded successfully

* X460-48p.7 # install image
Image file name
"summitX-15.5.1.6-LegacyCLI.xmod"
* X460-48p.7 # install image "summitX-15.5.1.6-LegacyCLI.xmod"
Execute the command
reboot Reboot after installation complete
Partition
"primary" "secondary"

If you execute the command install image and then "?" mark then you would see that what image had downloaded in the switch memory.

Hope this will help you.
Thank you, and I hadn't thought of that! Is it sitting in NVRAM?

I will be installing soon, and I appreciate all of your help.

Thanks,
-Theo
I received an error when trying to install the image file.

The command syntax is as follows: "download image [i] summitX-15.3.2.11-LegacyCLI.xmod vr "VR-Default" primary"

Error: Failed to install image on Slot-4 - version mismatch between XOS and xmod
Failed to install image on Slot-1 - version mismatch between XOS and xmod
Failed to install image on Slot-2 - version mismatch between XOS and xmod

So I ran the below show command and found that my primary and secondary partitions on each slot are different.

* Slot-3 Travis-MDF-440.6 # show version images
Card Partition Installation Date Version Name Branch
------------------------------------------------------------------------------
Slot-1 primary Fri Aug 17 22:21:13 UTC 2012 15.2.1.5 summitX450-15.2.1.5.xos v1521b5
Slot-1 secondary Sat Nov 9 04:54:32 UTC 2013 15.3.2.11 summitX-15.3.2.11.xos v1532b11
Slot-2 primary Fri Aug 17 22:21:13 UTC 2012 15.2.1.5 summitX450-15.2.1.5.xos v1521b5
Slot-2 secondary Sat Nov 9 04:50:59 UTC 2013 15.3.2.11 summitX-15.3.2.11.xos v1532b11
Slot-3 primary Tue Nov 23 18:22:18 UTC 2010 12.5.1.6 summitX450-12.5.1.6.xos v1251b6
Slot-3 secondary Sat Nov 23 05:11:32 UTC 2013 15.3.2.11 summitX-15.3.2.11.xos v1532b11
Slot-4 primary Tue Nov 23 18:22:18 UTC 2010 12.5.1.6 summitX450-12.5.1.6.xos v1251b6
Slot-4 secondary Sat Nov 23 05:17:31 UTC 2013 15.3.2.11 summitX-15.3.2.11.xos v1532b11

Can I install this XMOD onto the secondary partition on slot-3? Will the XMOD still function properly?
Userlevel 4
I would suggest to boot all the switches in same partition and then try to install Xmod image.
How would I boot into another partition? Does my partition determine the running config? If I do this, will I have to apply a backup config to return my stack to the state it was running at before I booted from a different partition?

If I wanted to get the stack running the same version, how would I go about doing that also?
I ran the commands "show switch" and "show version" and it seems that the stack is running off of the secondary partition already. So when I run the "install image" command, I just select as an option at the end of the syntax, correct?

* Slot-3 Travis-MDF-440.1 # show switch
SysName: Travis-MDF-440
SysLocation:
SysContact: support@extremenetworks.com, +1 888 257 3000
System MAC: 02:04:96:52:88:82
System Type: X450e-48t (Stack)

SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled

Current Time: Mon Jun 16 21:07:09 2014
Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time: Tue Nov 26 06:07:33 2013
Boot Count: 16
Next Reboot: None scheduled
System UpTime: 202 days 14 hours 59 minutes 36 seconds

Slot: Slot-3 * Slot-4
------------------------ ------------------------
Current State: MASTER BACKUP (In Sync)

Image Selected: secondary secondary
Image Booted: secondary secondary
Primary ver: 12.5.1.6 12.5.1.6
Secondary ver: 15.3.2.11 15.3.2.11

Config Selected: primary.cfg
Config Booted: primary.cfg

primary.cfg Created by ExtremeXOS version 15.3.2.11
553952 bytes saved on Mon Nov 25 23:16:08 2013

* Slot-3 Travis-MDF-440.2 # show version
Slot-1 : 800474-00-10 1331N-45227 Rev 10.0 BootROM: 2.0.1.7 IMG: 15.3.2.11
Slot-2 : 800474-00-10 1331N-45228 Rev 10.0 BootROM: 2.0.1.7 IMG: 15.3.2.11
Slot-3 : 800391-00-01 1129G-81432 Rev 1.0 BootROM: 1.0.5.6 IMG: 15.3.2.11
Slot-4 : 800391-00-01 1129G-81431 Rev 1.0 BootROM: 1.0.5.6 IMG: 15.3.2.11
Slot-5 :
Slot-6 :
Slot-7 :
Slot-8 :

Image : ExtremeXOS version 15.3.2.11 v1532b11 by release-manager
on Tue Jun 18 15:59:06 EDT 2013
BootROM : 1.0.5.6
Diagnostics : 5.10
Userlevel 4
I personally won't recommend to use EXOS 15.3.2 software. I would rather recommend to install EXOS 15.3.1 patch 1-38.

The master hold configuration for all the slots.

Your switch is using the software from the secondary partition(image booted: seconday).

You could execute below command in order to install correct image:

download image [i] summitX-15.3.2.11-LegacyCLI.xmod vr "VR-Default" secondary
So I should update my primary partition or roll my secondary back a version and then install?

Reply