I Cant make ospf between two Extreme Swichtes through a L2 link with a LAG configuration between then?


Hi everybody, I'm having a problem with two switches that are connected via a L2 Service Provider, and there is a LAG between one of the switches and the SP Switch. This LAG is up, but when I actívate the OSPF I cant make the switches run the OSPF. Down I show the relevant configuration. The vlan betweem them is 3794

Switch1:
enable ospf
configure ospf add vlan B-Lim-Ar area 0.0.0.0
create vman "B-Lim-Ar"
configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 12 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ports 12 display-string TO_B
configure ports 12 auto on speed 1000 duplex full
configure ports 12 ethertype secondary

* SBJ-EXT_AGREG.74 # show ospf area detail
IP addr Ospf State DR IP addr BDR IP addr
60.60.60.1 /29 E DR 60.60.60.1 0.0.0.0

Switch2 with LAG:
enable ospf
configure ospf add vlan AqpLima area 0.0.0.0
create vman "AqpLima"
configure vman AqpLima tag 3794
configure vman AqpLima add ports 44 tagged
configure vlan AqpLima ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan AqpLima
configure ospf add vlan AqpLima area 0.0.0.0
configure ports 44 display-string TO_Bit
configure ports 44 auto off speed 1000 duplex full
configure ports 44 ethertype secondary
enable sharing 44 grouping 44-45 algorithm address-based L3 lacp

EXTR_AQP.137 # show lacp lag 44 detail
* EXTR_AQP.138 # C-Collecting, D-Distributing, F-Defaulted, E-ExpiredActor Flags: A-Activity, T-Timeout, G-Aggregation, S-Synchronization================================================================================45 0 Current Selected Collect-Dist A-GSCD-- 2 44 0 Current Selected Collect-Dist A-GSCD-- 1 --------------------------------------------------------------------------------Port Priority State Logic State Flags Port Member Port Rx Sel Mux Actor Partner Port list: T.pri:32768, T.id:e0:24:7f:fc:a4:59, L:0x0a31 S.pri:0 , S.id:00:04:96:99:9e:4e, K:0x0414LAG Id flag : YesStandby count : 0Selected count : 2Minimum active : 1Transmit state : EnabledReceive state : EnabledDefaulted Action : DeleteActivity mode : ActiveCurrent timeout : LongWait-for-count : 0Unack count : 0LAG State : UpEnabled : Yes44 0 0x0414 e0:24:7f:fc:a4:59 32768 0x0a31 2 00:04:96:99:9e:4e-------------------------------------------------------------------------------- Sys-Pri Key MAC Sys-Pri Key Count MAC Lag Actor Actor Partner Partner Partner Agg Actor

* EXTR_AQP.129 # show ospf area detail
IP addr Ospf State DR IP addr BDR IP addr
60.60.60.2 /29 E DR 60.60.60.2 0.0.0.0

I have tried it with LAG algorithm address-based L2 but its the same problem. The SP switch is Huawei. Thanks in advance for your suggestions.

22 replies

I solved the problem, it was that the Router ID was the same in both switches, change one of them and OSPF got established. Thank you all for helping me
Userlevel 7
If OSPF hellos are transmitted, the respective multicast group 224.0.0.5 can be seen using
show mcast cache group 224.0.0.5/32[/code]or
show igmp group 224.0.0.5[/code]
Userlevel 6
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... 🙂
Userlevel 7
Hi Edison,

thanks for letting us know what caused the problem. :-)

Erik
Userlevel 6
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Article with the configuration steps in the link below:
How to create OSPF neighbor using LAG and VMAN?
Userlevel 7
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Hello Henrique,

for your consideration: for a documentation article it would be more appropriate to use IP addresses from the ranges reserved for documentation (https://tools.ietf.org/html/rfc5737), e.g. 192.0.2.1 and 192.0.2.2.

Thanks,
Erik
Userlevel 6
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Hi Erik, just updated the article.

Thanks for pointing this. 🙂
Userlevel 7
Hello Edison,

I do not think you can use routing (or layer 3 forwarding) on a VMAN, you would need to use a VLAN. I wonder how you can have both a VMAN and a VLAN with the same name.

Erik
Userlevel 5
The most likely cause is the licensing on the switches. Do a "show license" and make sure at least one of them has a core license installed, if you don't that one can never be the DR. Without a DR you need to configure the links as point-to-point.
The most likely cause is the licensing on the switches. Do a "show license" and make sure at least one of them has a core license installed, if you don't that one can never be the DR. Without a DR you need to configure the links as point-to-point. I have just check it and both have core license, please if you know the commands to configure point-to-point OSPF I would aprecciate it.
Hello Edison,

I do not think you can use routing (or layer 3 forwarding) on a VMAN, you would need to use a VLAN. I wonder how you can have both a VMAN and a VLAN with the same name.

Erik
I have made the configuration with:
configure vman B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248,
but when I watch it in show configuration it shows:
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
Userlevel 7
The most likely cause is the licensing on the switches. Do a "show license" and make sure at least one of them has a core license installed, if you don't that one can never be the DR. Without a DR you need to configure the links as point-to-point. Hello Edison,

that would be:
configure ospf add vlan VLAN_NAME area AREA_ID link-type point-to-point[/code]Erik
Userlevel 7
Hello Edison,

I do not think you can use routing (or layer 3 forwarding) on a VMAN, you would need to use a VLAN. I wonder how you can have both a VMAN and a VLAN with the same name.

Erik
Do you have IP connectivity between the two interfaces?
ping 60.60.60.2 from 60.60.60.1[/code]ping 60.60.60.1 from 60.60.60.2[/code]Erik
The most likely cause is the licensing on the switches. Do a "show license" and make sure at least one of them has a core license installed, if you don't that one can never be the DR. Without a DR you need to configure the links as point-to-point. Ok Thanks
Hello Edison,

I do not think you can use routing (or layer 3 forwarding) on a VMAN, you would need to use a VLAN. I wonder how you can have both a VMAN and a VLAN with the same name.

Erik
Yes I do have ping between them.
Userlevel 5
Thinking about this, I do not think OSPF will work on a VMAN even if you can ping it. Can you configure it on a VLAN and try again?
Userlevel 5
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Thanks.. I am traveling otherwise I would have set it up too.
Userlevel 6
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Anytime.

I'm already working on a replication with OSPF and ISIS and spent just 3 minutes on that. 🙂
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Ok Thank you , I will try that later witj the point to point configuration, but what about the LAG Do you know if there any problem with the balancing algorithm and OSPF?
Userlevel 6
Hi,

I have created the vman and configured ipaddress, ipforwarding and OSPF to the same string/name but using vlan word instead of vman.

SW-A ----- 23 ---- OSPF ---- 11 ------- SW-B

SW-A:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 23 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.1 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

SW-B:

create vman "B-Lim-Ar"configure vman B-Lim-Ar tag 3794
configure vman B-Lim-Ar add ports 11 tagged
configure vlan B-Lim-Ar ipaddress 60.60.60.2 255.255.255.248
enable ipforwarding vlan B-Lim-Ar
configure ospf add vlan B-Lim-Ar area 0.0.0.0 link-type point-to-point
enable ospf

Neighbor ID Pri State Up/Dead Time Address Interface
========================================================================

2.2.2.2 1 FULL /DROTHER 00:00:03:36/00:00:00:06 60.60.60.2 B-Lim-Ar

OSPF Neighbor established and I could see all routes learned by its neighbor.

That's interesting... :-)

Hi Edison, I don't see any issue using LACP and OSPF.
Userlevel 6
Hi Edison,

Just curious about the configured value for the secondary ether type.

Please share the output of "show vman ethertype"

If the issue is still present, we may need to check if the hellos are being forwarded between the switches via the L2 Service provider.

Thanks in advance.
Hi Edison,

Just curious about the configured value for the secondary ether type.

Please share the output of "show vman ethertype"

If the issue is still present, we may need to check if the hellos are being forwarded between the switches via the L2 Service provider.

Thanks in advance.

Hi Prashanth

* SBJ-EXT_AGREG.1 # show vman etherType
Vman Primary EtherType : 0x88a8
Vman Secondary EtherType : 0x8100

* SBJ-EXT_AGREG.2 # Secondary EtherType ports : 2 3 4 5g 6 7 9 10 11 12 14 17 18 19 21 26 48

* EXTR_AQP.1 # show vman etherType
Vman Primary EtherType : 0x88a8
Vman Secondary EtherType : 0x8100

Secondary EtherType ports : 1 3 5 9 44g 46 47 48
* EXTR_AQP.2 #

Reply