Illegal password characters in XOS?


Userlevel 1
Are there illegal password characters in XOS? As an example, I had been trying to change a password on a Summit running 15.2.1.5 to k&4D#hE$w(Wf but the switch responds as below after entering that PW at the "New Password:" and "Reenter password:" prompts and the PW isn't changed.

* Summit-CV-Core.5 # config account smithj
Current user's password:
New password:
Reenter password:
Error: not well-formed (invalid token)

Password policy on the Summit is as follows:
Password Max. age : None
Password History limit : 4
Password Min. length : 8
Password Character Validation : Disabled
Accts. lockout on login failures: Disabled
Accounts locked out : No

5 replies

Userlevel 5
Stephen,

I just tried the same password on a new account 15.7 and it worked fine. I will try this on a later version of code and let you know, in this case I created a new account "bill" and my password policy looks as follows:

RDU-EBC-BDX8-2.2 # sh accounts password-policy---------------------------------------------------------------------------
Accounts global configuration (applied to new accounts on creation)
---------------------------------------------------------------------------
Password Max. age : None
Password History limit : None
Password Min. length : None
Password Character Validation : Disabled
Accts. lockout on login failures: Disabled
Accounts locked out : No
-----------------------------------------------------------------------------
User Name Password Password Password Password Flags
Expiry Max. age Min. len History
Date Limit
-----------------------------------------------------------------------------
admin None None None ---
user None None None ---
bill None None None ---
-----------------------------------------------------------------------------
Flags: (C) Password character validation enabled, (L) Account locked out
(l) Account lockout on login failures enabled
RDU-EBC-BDX8-2.3 #
:
Userlevel 1
I just tried the same PW on a switch with 15.3.1.4 and it worked fine. I tried removing the "&" in the PW and that was apparently the conflicting issue with 15.2.
Userlevel 5
Agreed.. Just tried it with 15.3 and it worked too... Hope all is well with you.

Bill
Userlevel 4
Hi Stephen, Bill,

This is known issue resolved by CR xos0051121.

"Existing account password cannot be changed if password string contains '&' or '<' special characters."

Fixed in EXOS 15.1.5, 15.2.4, 15.3.2, 15.4.1 and later.
Userlevel 4
GTAC Knowledge Article:
http://gtacknowledge.extremenetworks.com/articles/Q_A/Are-There-Illegal-Password-Characters-in-XOS/?...

Reply