Incorrect carrier vlan configuration of port


I am trying to enable PVST+ on our Black Diamond switch.

When I try to enable certain STP instances, I get an error:

Ops_BD8810.2 # configure stpd AB-Level2 tag 2602 Ops_BD8810.3 # enable stpd AB-Level2 Error: Incorrect carrier vlan configuration of port 4:41 in stp domain AB-Level2 Configuration failed on backup MSM, command execution aborted! [/code]I am not sure why this happens, seems to not have a problem with port 2:9:

Ops_BD8810.9 # sh ports 4:41 info dePort: 4:41
Virtual-router: VR-Default
Type: UTP
Random Early drop: Unsupported
Admin state: Enabled with auto-speed sensing auto-duplex
Link State: Ready
Link Counter: Up 0 time(s)

VLAN cfg:
Name: AB-Level2, Internal Tag = 2602, MAC-limit = No-limit, Virtual router: VR-Default
STP cfg:
AB-Level2(disable), Tag=2602, Mode=PVST+, State=DISABLED[/code]-------------------------------------------------------------------------- Ops_BD8810.10 # sh stp "AB-Level2" Stpd: AB-Level2 Stp: DISABLED Number of Ports: 3
Rapid Root Failover: Disabled
Operational Mode: 802.1W Default Binding Mode: PVST+
802.1Q Tag: 2602
Ports: 2:9*,4:41,10:10
Participating Vlans: AB-Level2
Auto-bind Vlans: (none)
Bridge Priority: 32768
BridgeID: 80:00:00:04:96:1e:23:50
Designated root: 00:00:00:00:00:00:00:00
RootPathCost: 0 Root Port: ----
MaxAge: 0s HelloTime: 0s ForwardDelay: 0s
CfgBrMaxAge: 20s CfgBrHelloTime: 2s CfgBrForwardDelay: 15s
Topology Change Time: 35s Hold time: 1s
Topology Change Detected: FALSE Topology Change: FALSE
Number of Topology Changes: 0
Time Since Last Topology Change: 0s[/code]

2 replies

Userlevel 4
Evan,

When setting up STP for version PVST+ the ports expected to transmit BPDUs must be tagged. Can you try to tag VLAN 2602 on port 4:41 and see if the error clears?

Andrew
Userlevel 6
Hi Evan,

The port 4:41 is untagged in the VLAN. For the STP ports to operate in a mode than dot1d, that port should be tagged in the VLAN which contains the STP tag since those ports are used for carrying the BPDUs with the specified VLAN tag.

So, if possible, add the port 4:41 as tagged in the VLAN or if it has to be an untagged port, change the STP mode for that port to dot1d using the command,

configure stpd ports mode dot1d 4:41.

Hope this helps!

Reply