Header Only - DO NOT REMOVE - Extreme Networks

invalid ssh key after config restore


Userlevel 2
Dear all.

ssh is not working after restore a previously saved config.

1. save config new.cfg
2. unconfigure switch all
3. use configuration new.cfg
4 reboot

The configuration is loaded successful and complete, but ssh is not working anymore. Connection error.

checking "show management" show me an invalid ssh key.

X460G2-24p-10G4.3 # show management

...
SSH access : Disabled (Key invalid, tcp port 22 vr all)
: Secure-Mode : Off
: Access Profile : not set
SSH2 idle time : 60 minutes
...

I need to renew the key by "configure ssh2 key"

Any Idea how to fix it?

Thanks
Alex

[/code][/code]

7 replies

Userlevel 6
Hello!

1
https://gtacknowledge.extremenetworks.com/articles/Q_A/Will-SSH-is-enabled-by-uploading-the-configur...

2
https://gtacknowledge.extremenetworks.com/articles/How_To/Install-SSH-Key/

Thank you!
Userlevel 2
Hi Alexandr.

thanks for your fast feedback.

This is bad...
I will talk to GTAC about this.

regards
Alex
Userlevel 4
aloeffle wrote:

Hi Alexandr.

thanks for your fast feedback.

This is bad...
I will talk to GTAC about this.

regards
Alex

Hello Alex,
If your switch is running at 16.2 or 21.3, then it was possible trigger below CR.There is workaround from below article if you really hit it.

https://gtacknowledge.extremenetworks.com/articles/Solution/Switch-gets-into-reboot-loop-if-configur...
Userlevel 2
aloeffle wrote:

Hi Alexandr.

thanks for your fast feedback.

This is bad...
I will talk to GTAC about this.

regards
Alex

Hi Steven.

we run 22.2.x on all of our devices...

thx

Alex
Userlevel 3
Did try to do ‘run update’ and ‘restart process thttpd’?
Userlevel 2
Ram wrote:

Did try to do ‘run update’ and ‘restart process thttpd’?

Hi Ram.

to make the ssh key valid again, I need to execute "configure ssh2 key".

Then a new key is generated and ssh is working again. The problem is, that this can not be done remote. I need onsite access.

regards

Alex
Userlevel 1
Ram wrote:

Did try to do ‘run update’ and ‘restart process thttpd’?

We had the ssh key go invalid on us after a config restore as well. Thanks, as finding this thread helped us. Regenerating the key fixed this issue.

Reply