Question

IP phones register only when voice vlan allowed


Userlevel 1
We have 6 floors , we have IP phones connected to switch and PC connects from IP phone. In one floor IP phones register/work only when voice vlan is allowed. If I allow both voice and data on one port then phone not working. In other floors ip phones are working with both voice and data vlans allowed on ports.

17 replies

Userlevel 1
is lldp or cdp being used for configuration ?
Userlevel 1
Aleixo Gomes wrote:

is lldp or cdp being used for configuration ?

no
Userlevel 3
yes, we can help more if you tell us more... What kind of phones?

most IP phones need to be told what vlan to tag themselves in to use as voice.

the way you "tell" them is via LLDP / CDP/ DHCP...

if you cant find the difference in the switches look to the dhcp server for option that may be pointing the phones to a vlan...
Userlevel 1
David Rahn wrote:

yes, we can help more if you tell us more... What kind of phones?

most IP phones need to be told what vlan to tag themselves in to use as voice.

the way you "tell" them is via LLDP / CDP/ DHCP...

if you cant find the difference in the switches look to the dhcp server for option that may be pointing the phones to a vlan...

ip phones (Avaya) , they have static IP configured.

Voice is tagged and data is untagged
Userlevel 4
A sample of your configuration would be helpful as well as the version of firmware that you have deployed in your network.
Userlevel 1
Pls find the config below of the stack switch on which we are observing the issue:

The only difference between this switch and other floor switches are stpd s0 is enabled on this switch:

software version: 15.1.5.4

configure snmp sysName "xyz"configure timezone name IST 330 noautodst
configure slot 1 module X460-48p
configure sys-recovery-level slot 1 reset
configure slot 2 module X460-48p
configure sys-recovery-level slot 2 reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1:1-54, 2:1-54
configure vr VR-Default add ports 1:1-54, 2:1-54
configure vlan default delete ports 1:1-54, 2:1-54
create vlan "NMS"
configure vlan NMS tag 40
create vlan "USER"
configure vlan USER tag 20
create vlan "VOICE"
configure vlan VOICE tag 10
configure ports 1:53 auto off speed 10000 duplex full
configure ports 1:54 auto off speed 10000 duplex full
configure ports 2:53 auto off speed 10000 duplex full
configure ports 2:54 auto off speed 10000 duplex full
configure vlan NMS add ports 1:53-54, 2:53-54 tagged
configure vlan USER add ports 1:53-54, 2:53-54 tagged
configure vlan USER add ports 1:1-44, 2:1-44 untagged
configure vlan VOICE add ports 1:1-48, 1:53-54, 2:1-48, 2:53-54 tagged
configure vlan Mgmt ipaddress 192.168.1.1 255.255.255.0
configure vlan NMS ipaddress 192.168.100.24 255.255.255.0


#
configure iproute add default 192.168.100.1

# Module elrp configuration.
#
enable elrp-client
configure elrp-client periodic NMS ports all interval 1 log-and-trap disable-port permanent
configure elrp-client periodic USER ports all interval 1 log-and-trap disable-port permanent
configure elrp-client periodic VOICE ports all interval 1 log-and-trap disable-port permanent
configure elrp-client disable-port exclude 1:53
configure elrp-client disable-port exclude 1:54
configure elrp-client disable-port exclude 2:53
configure elrp-client disable-port exclude 2:54

# Module lldp configuration.

# Module stp configuration.

configure mstp region 0204966ce708
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
create stpd STPD-NMS
configure stpd STPD-NMS mode dot1w
configure stpd STPD-NMS default-encapsulation pvst-plus
create stpd STPD-USER
configure stpd STPD-USER mode dot1w
configure stpd STPD-USER default-encapsulation pvst-plus
create stpd STPD-VOICE
configure stpd STPD-VOICE mode dot1w
configure stpd STPD-VOICE default-encapsulation pvst-plus
enable stpd STPD-NMS auto-bind vlan NMS
enable stpd STPD-USER auto-bind vlan USER
enable stpd STPD-VOICE auto-bind vlan VOICE
enable stpd s0
configure stpd STPD-NMS tag 40
enable stpd STPD-NMS
configure stpd STPD-USER tag 20
enable stpd STPD-USER
configure stpd STPD-VOICE tag 10
enable stpd STPD-VOICE

#
# Module telnetd configuration.
#
Userlevel 1
Any update ........
Userlevel 3
Avaya ip phone statically ip addressed need the tag static assigned in the config. Also in the 46xxsettings.txt file you can manipulate the ethernet tagging options.
Userlevel 1
David Rahn wrote:

Avaya ip phone statically ip addressed need the tag static assigned in the config. Also in the 46xxsettings.txt file you can manipulate the ethernet tagging options.

Sorry

Didn't get that can you brief please.

But how come same avaya phones are working with static IPS on other floors.
Userlevel 6
Hi,

If that works only when "VOICE" vlan is configured, I guess that ipaddress and vlan tag is already configured correctly in the phones otherwise it would work only when using "USER" vlan because that vlan is configured to accept only untagged frames on user ports...

Would be great to configure an IP in both vlans "USER" and "VOICE", plug both Phone and PC and try to ping from the switch to both PC and Phone IPs.

Then we can check if at least there are some communication to the phone and PC.
Userlevel 1
Henrique wrote:

Hi,

If that works only when "VOICE" vlan is configured, I guess that ipaddress and vlan tag is already configured correctly in the phones otherwise it would work only when using "USER" vlan because that vlan is configured to accept only untagged frames on user ports...

Would be great to configure an IP in both vlans "USER" and "VOICE", plug both Phone and PC and try to ping from the switch to both PC and Phone IPs.

Then we can check if at least there are some communication to the phone and PC.

Hi Henri que

You mean to say config is fine and
I need to assign ip to phone and ip to PC and ping both from switch

Or assign l3 iP address for both user and voice vlan on switch
Userlevel 6
Henrique wrote:

Hi,

If that works only when "VOICE" vlan is configured, I guess that ipaddress and vlan tag is already configured correctly in the phones otherwise it would work only when using "USER" vlan because that vlan is configured to accept only untagged frames on user ports...

Would be great to configure an IP in both vlans "USER" and "VOICE", plug both Phone and PC and try to ping from the switch to both PC and Phone IPs.

Then we can check if at least there are some communication to the phone and PC.

Yes, you are correct.
Userlevel 1
Henrique wrote:

Hi,

If that works only when "VOICE" vlan is configured, I guess that ipaddress and vlan tag is already configured correctly in the phones otherwise it would work only when using "USER" vlan because that vlan is configured to accept only untagged frames on user ports...

Would be great to configure an IP in both vlans "USER" and "VOICE", plug both Phone and PC and try to ping from the switch to both PC and Phone IPs.

Then we can check if at least there are some communication to the phone and PC.

Correct with which one :

1) assign ip to both phone and PC
2) assign l3 ip to both vlans on L2 switch
Userlevel 6
Henrique wrote:

Hi,

If that works only when "VOICE" vlan is configured, I guess that ipaddress and vlan tag is already configured correctly in the phones otherwise it would work only when using "USER" vlan because that vlan is configured to accept only untagged frames on user ports...

Would be great to configure an IP in both vlans "USER" and "VOICE", plug both Phone and PC and try to ping from the switch to both PC and Phone IPs.

Then we can check if at least there are some communication to the phone and PC.

Both 1 and 2 🙂

I would like to check if you can ping both PC and phone from the switch when you have both vlans configured to the port.
Userlevel 3
What do you mean in original question by when voice is allowed... is that tagged or untagged? I assume it works when voice is untagged on port, this tells me that phone is set up wrong and you have 802.1q disabled or van incorrectly defined in phone settings
Userlevel 1
Hi David Voice vlan is tagged and user vlan as untaged.
Userlevel 7
Hello Sai Prasad,
It's been a month since the last update in this thread. Were you able to resolve this issue?

Reply