Question

L2 protocol tunneled across L2VPN PW not working

  • 9 September 2019
  • 1 reply
  • 49 views

Userlevel 5
Hi Community

I need to pass LLDP traffic between two switches that is connected to each other over a L2VPN pseudowire.
Below is a high level network diagram:




I am using x460-G2 switches as the MPLS switches that runs MPLS with LDP and it estabilishes the VPWS between the two PE's.

The VPWS is working fine as I can pass normal user traffic between the two switches.
However I do not see LLDP passed across the VPWS.

I have followed the below article but i still do not see the LLDP traffic passed across the VPWS:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-l2pt-profile-in-Extreme-Switches/?q=l2pt&l=en_US&fs=Search&pn=1

I have the following config on both the PE's:

(Not showing the MPLS config as the service is working)

create vman "PW1"
configure vman PW1 tag 211
configure vman PW1 add ports 5 untagged

create l2pt profile "L2_Tunnel"
configure l2pt profile "L2_Tunnel" add protocol filter "lldp"
configure vlan "PW1" ports 5 l2pt profile "L2_Tunnel"

PE1# show vman "PW1" ports 5 l2pt detail
Port 5
L2PT Profile Name : L2_Tunnel

Protocol Filter Name : lldp
Destination Address: 01:80:c2:00:00:0e
Protocol Id Type : etype
Protocol Id Value : 0x88CC
Field Offset :
Field Value :
Field Mask :
Action : Tunnel
CoS :
Packets Transmitted: 0
Packets Received : 8


I can see on both PE's that they receive packets matching LLDP but never transmit them.

Any help would be appreciated.

Thx

1 reply

Userlevel 2
Is LLDP active on the ports on the PEs (enable lldp ports x)? I imagine that could "eat" your LLDP frames before they reach the filters. Then again, LLDP may not even be configurable on ports with MPLS config on them, don't really know, sorry! Try "disable lldp ports x" if you haven't.

B.t.w., you have moe MAC addresses for LLDP than just one:

01:80:c2:00:00:0e
01:80:c2:00:00:03
01:80:c2:00:00:00

Expanding the filter might do the trick.

/Fredrik

Reply