No IEEE 802.1AS Capable on Summit X440-24t switch


Dear Experts,

I have a Summit X440-24t AVB switch with AVB enabled. I am connecting an AVB endpoint to the switch, which is running gPTP. The switch reports that the port is not "IEEE 802.1AS Capable" when I run the "show network-clock gptp" command. The propagation delay is being measured and it is below the threshold (4000ns, threshold is 10000ns). The connected AVB endpoint is sending gPTP announce messages. What are the possible reasons that "IEEE 802.1AS Capable" is set to "No" and "Port Role" is set to "3 (Disabled)"?

Thank you,
Jakub Mielczarek

8 replies

Userlevel 6
Jakub,

The most common reason would be the peer delay threshold being exceeded. 4000ns is pretty long for a copper port (assuming this is copper). Is there some kind of media converter in between?

Could you paste in the following outputs:

show network-clock gptp ports
show network-clock gptp ports counters
show network-clock gptp parent-set
Hi Chad,

I am using a media converter and 100Mps link.
Here is the output you requested:

* X440-24t.4 # show network-clock gptp ports 11
Physical port number : 11
gPTP port status : Enabled
Clock Identity : 00:04:96:ff:fe:97:f3:c8
gPTP Port Number : 11
IEEE 802.1AS Capable : No
Port Role : 3 (Disabled)
Announce Initial Interval : 0 (1.000 secs)
Announce Current Interval : 0 (1.000 secs)
Announce Receipt Timeout : 3
Sync Initial Interval : -3 (0.125 secs)
Sync Current Interval : -3 (0.125 secs)
Sync Receipt Timeout : 3
Sync Receipt Timeout Interval : 0 ns
Measuring Propagation Delay : Yes
Propagation Delay : 4011 ns
Propagation Delay Threshold : 10000 ns
Propagation Delay Asymmetry : 0
Peer Delay Initial Interval : 0 (1.000 secs)
Peer Delay Current Interval : 0 (1.000 secs)
Peer Delay Allowed Lost Responses : 3
Neighbor Rate Ratio : 1.002489
PTP Version : 2

* X440-24t.5 # show network-clock gptp ports 11 counters
Port number : 11
gPTP port status : Enabled
------------------------------------------------------------
Parameter Receive Transmit
------------------------------------------------------------
Announce 956 2310
Sync 17592 18495
Follow Up 0 18495
Peer Delay Request 3401 109847
Peer Delay Response 3504 3401
Peer Delay Response Follow Up 3504 3401
gPTP packet discards 106320 -
------------------------------------------------------------
Announce Receipt Timeout Count : 0
Sync Receipt Timeout Count : 0
Peer Delay Allowed Lost Response Exceeded Count : 106214

* X440-24t.6 # show network-clock gptp parent-set
Parent Clock Identity : 00:04:96:ff:fe:97:f3:c8
Parent port number : 0
Cumulative Rate Ratio : 0
GM Clock Identity : 00:04:96:ff:fe:97:f3:c8
GM Clock Accuracy : 254 (Unknown)
GM Offset Scaled Log Variance : 17258
GM Priority1 : 246
GM Priority2 : 248

Thanks,
Jakub
Userlevel 6
Jakub,

Is it possible to temporarily test with copper only, eliminating the media converter (assuming endpoint is also copper.)

* X440-24t.5 # show network-clock gptp ports 11 counters
[/code]Port number : 11
gPTP port status : Enabled
------------------------------------------------------------
Parameter Receive Transmit
------------------------------------------------------------
Announce 956 2310
Sync 17592 18495
Follow Up 0 18495
Peer Delay Request 3401 109847
Peer Delay Response 3504 3401
Peer Delay Response Follow Up 3504 3401
gPTP packet discards 106320 -
------------------------------------------------------------
Announce Receipt Timeout Count : 0
Sync Receipt Timeout Count : 0
Peer Delay Allowed Lost Response Exceeded Count : 106214[/code]It seems that the endpoint is having trouble responding to the peer delay requests being generated by the switch. The number of peer delay request transmits should be very close, if not identical, to the peer delay response receive counter. There is a big disparity here and many gPTP rx discards. The peer delay lost response exceeded counter is also high.
Userlevel 6
Jakub,

Were you able to get this working?
Hi,

Not yet, I was on vacation the last week. Will try to figure it out.

Thanks,
Jakub
did you ever get it working - I am having a similar issue

Thanks!
John
I had to suspend work on this topic for a while. I am back at it. It still does not work with media converter and my gptp endpoint.

Here is the output from switch console:
=========================================================
* X440-24t.38 # show network-clock gptp port 15 counters
Port number : 15
gPTP port status : Enabled
------------------------------------------------------------
Parameter Receive Transmit
------------------------------------------------------------
Announce 60 0
Sync 952 0
Follow Up 0 0
Peer Delay Request 60 64
Peer Delay Response 64 60
Peer Delay Response Follow Up 64 60
gPTP packet discards 0 -
------------------------------------------------------------
Announce Receipt Timeout Count : 0
Sync Receipt Timeout Count : 0
Peer Delay Allowed Lost Response Exceeded Count : 0
=========================================================
* X440-24t.38 # show network-clock gptp ports 15
Physical port number : 15
gPTP port status : Enabled
Clock Identity : 00:04:96:ff:fe:97:f3:c8
gPTP Port Number : 15
IEEE 802.1AS Capable : No
Port Role : 3 (Disabled)
Announce Initial Interval : 0 (1.000 secs)
Announce Current Interval : 0 (1.000 secs)
Announce Receipt Timeout : 3
Sync Initial Interval : -3 (0.125 secs)
Sync Current Interval : -3 (0.125 secs)
Sync Receipt Timeout : 3
Sync Receipt Timeout Interval : 0 ns
Measuring Propagation Delay : Yes
Propagation Delay : 4029 ns
Propagation Delay Threshold : 10000 ns
Propagation Delay Asymmetry : 0
Peer Delay Initial Interval : 0 (1.000 secs)
Peer Delay Current Interval : 0 (1.000 secs)
Peer Delay Allowed Lost Responses : 3
Neighbor Rate Ratio : 1.002490
PTP Version : 2

=========================================================

* X440-24t.39 # show network-clock gptp parent-set
Parent Clock Identity : 00:04:96:ff:fe:97:f3:c8
Parent port number : 0
Cumulative Rate Ratio : 0
GM Clock Identity : 00:04:96:ff:fe:97:f3:c8
GM Clock Accuracy : 254 (Unknown)
GM Offset Scaled Log Variance : 17258
GM Priority1 : 246
GM Priority2 : 248

Any help highly appreciated.

Regards,
Jakub
Jakub Mielczarek wrote:

I had to suspend work on this topic for a while. I am back at it. It still does not work with media converter and my gptp endpoint.

Here is the output from switch console:
=========================================================
* X440-24t.38 # show network-clock gptp port 15 counters
Port number : 15
gPTP port status : Enabled
------------------------------------------------------------
Parameter Receive Transmit
------------------------------------------------------------
Announce 60 0
Sync 952 0
Follow Up 0 0
Peer Delay Request 60 64
Peer Delay Response 64 60
Peer Delay Response Follow Up 64 60
gPTP packet discards 0 -
------------------------------------------------------------
Announce Receipt Timeout Count : 0
Sync Receipt Timeout Count : 0
Peer Delay Allowed Lost Response Exceeded Count : 0
=========================================================
* X440-24t.38 # show network-clock gptp ports 15
Physical port number : 15
gPTP port status : Enabled
Clock Identity : 00:04:96:ff:fe:97:f3:c8
gPTP Port Number : 15
IEEE 802.1AS Capable : No
Port Role : 3 (Disabled)
Announce Initial Interval : 0 (1.000 secs)
Announce Current Interval : 0 (1.000 secs)
Announce Receipt Timeout : 3
Sync Initial Interval : -3 (0.125 secs)
Sync Current Interval : -3 (0.125 secs)
Sync Receipt Timeout : 3
Sync Receipt Timeout Interval : 0 ns
Measuring Propagation Delay : Yes
Propagation Delay : 4029 ns
Propagation Delay Threshold : 10000 ns
Propagation Delay Asymmetry : 0
Peer Delay Initial Interval : 0 (1.000 secs)
Peer Delay Current Interval : 0 (1.000 secs)
Peer Delay Allowed Lost Responses : 3
Neighbor Rate Ratio : 1.002490
PTP Version : 2

=========================================================

* X440-24t.39 # show network-clock gptp parent-set
Parent Clock Identity : 00:04:96:ff:fe:97:f3:c8
Parent port number : 0
Cumulative Rate Ratio : 0
GM Clock Identity : 00:04:96:ff:fe:97:f3:c8
GM Clock Accuracy : 254 (Unknown)
GM Offset Scaled Log Variance : 17258
GM Priority1 : 246
GM Priority2 : 248

Any help highly appreciated.

Regards,
Jakub

It works after fixing timestamp conversion in my endpoint. The Neighbor Rate Ratio could be the cause. Now the rate ratio is 0.999989

Reply