Header Only - DO NOT REMOVE - Extreme Networks

not able to configure sharing when using GNS3


Userlevel 1
I Start using GNS3 (Version 22.1.1.5) and trying to set up a link aggregation.

When using the standard sharing command I'm getting the following error:

* EXOS-VM.3 # enable sharing 1 grouping 1-2 algorithm address-based lacp[/code]Error: PC environment supports only round robin algorithm.[/code]
but Round Robin is not an option when doing the configuration:

* EXOS-VM.4 # enable sharing 1 grouping 1-2 algorithm ?[/code] address-based address based[/code]* EXOS-VM.4 # enable sharing 1 grouping 1-2 algorithm[/code]
Found out the rigth command for it and tried to configure:
[/code]* EXOS-VM.1 # enable sharing 1 grouping 1-2 algorithm roundRobin-based lacp[/code] ^[/code]%% Invalid input detected at '^' marker.[/code]anyone an idear how to fix that?

Thanks

7 replies

Userlevel 4
There are lots of limitaion on virtual EXOS switches and I remember LAG is one if them. Actually round robin is NOT a kind of algorithm for real switches. Just try "enable sharing 1 group 1-2" and it will work.
Userlevel 1
Thank you!
Userlevel 7
You still can add lacp on EXOS VM: "enable sharing 1 grouping 1,2 lacp"
Userlevel 4
The following example defines a static load-sharing group that contains ports 9 through 12, and uses the first port in the group as the master logical port 9:

enable sharing 9 grouping 9-12

In this example, logical port 9 represents physical ports 9 through 12.
When using load sharing, you should always reference the master logical port of the load-sharing group.

Coming to the algorithm used in LACP for extreme switches we may use either standard or custom algorithm. For more information you may refer to page 219 of EXOS user guide 21.1 PDF.
Userlevel 4
Nico we feel your concern is fixed after having followed up the above posted conversation.
Do let us know if you have any further concern. Else we can close this Hub conversation here.

Wish you in advance happy new year 2017 ............
Userlevel 1
Happy new Year...Yes all open questions are answered. Many thanks!
Userlevel 4
Thanks for letting us know to conclude this discussion now. Looking forward for more assistance in the future if you need any ......

Reply