Header Only - DO NOT REMOVE - Extreme Networks

Not able to Unconfigure - Summit x450 24P


Greetings!!!

I ran into a peculiar problem, where I am unable to unconfigure a switch that was part of an existing stack. Though, the switch was removed from the stack physically but it was not un-configured logically.

1. I tried un-configuring the stack.
2. Un-configuring the switch

After the reboot I saw that though there was no configuration in the switch but I can see the LED panel showing the same stack ID being shown that was assigned to it while it was a part of the stack.

I tried turning off the master capability - Didn't work.
I tried doing a factory reset - Configuration was removed but still it was showing slot no.2
in the bootrom I tried doing a config none. - it doesn't accept the command.
I tried upgrading the switch - the partition shows the same image that it was loaded with. (current ver 12.7.1.3)
I did a TFTP to use a new configuration file., through the file was in place. I am unable to use it.

I am just not able to get rid of the stack config thats in the switch.

I must be missing something very silly.

Regards
Manish

5 replies

Userlevel 6
Hi Manish,

In this case i would suggest to upgrade the switch from bootrom which should wipe out the complete switch to factory defaults.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Use-the-Boot-Rom-Menu-to-Download-a...

here is an article to help with the installation from bootrom
Userlevel 5
Manish,

You can do the following... you are most likely in "pending-AAA" - type "REBOOT AS MASTER-CAPABLE" when waiting, it will reboot and become master and allow you to login. Be aware this is a one-time event so be prepared with user/pass - Once you are in you can issue the "unconfigure switch all" -

Please let me know if you have any issues.

Bill
Userlevel 6
What command are you using to to unconfigure the switch? if you jsut type in "unconfigure switch" it will leave the stacking configuration and get rid of almost everything else. "unconfigure switch all" however blows out all of the configuration, even stacking.
Hi Karthik/Bill/Patrick,

Thanks for replying.

The only thing I haven't tried is booting a new image from the bootrom.

I actually did a unconfigure switch all. As I mentioned all the config was erased leaving the stack ID.

Will try and load a new image from bootrom and update.

Cheers
Userlevel 6
Hi Manish,

Just curious to know if you are able to login to the switch successfully through CLI or was it stuck in pending-aaa as Bill pointed out.

if you are able to login to the switch successfully, does the CLI prompt still shows that it is in stack?
if so, have you tried "disable stacking" and reboot?

I understand unconfigure switch all should have wiped out the stacking configuration. still, it might be worth a try to see if you can disable stacking and reboot.

upgrading from bootrom should help clear all the contents in the switch. Let us know how it goes!

Reply