Header Only - DO NOT REMOVE - Extreme Networks

One member of LAG is in a Defaulted State.

Hi Everyone, I am having a LACP LAG issue between two extreme switches. Extreme X460 and Extreme X440. Physically I get a link light on all 4 ports. However when looking through the cli I get the following output

Floor 7

Slot-1 SWStack_FL7.1 # show sharing
Load Sharing Monitor
Config Current Agg Ld Share Ld Share Agg Link Link Up
Master Master Control Algorithm Group Mbr State Transitions


1:1 1:1 Static L2 1:1 Y A 1

L2 2:1 - R 0

L2 3:1 - R 1

L2 4:1 - R 0

2:52 2:52 LACP L2 2:52 Y A 1

L2 5:52 Y A 2

3:52 3:52 LACP L2 3:52 Y A 2

L2 4:52 - R 2

[/code]Member Port Rx Sel Mux Actor Partner
Port Priority State Logic State Flags Port
3:52 0 Current Selected Collect-Dist A-GSCD-- 1052
4:52 0 Idle Unselected Detached -------- 0
================================================================================[/code]Here is the Output for Floor 13

Slot-1 SWStack_FL13.6 # show sharing
Load Sharing Monitor
Config Current Agg Min Ld Share Ld Share Agg Link Link Up
Master Master Control Active Algorithm Group Mbr State Transitions
1:52 1:52 LACP 1 L2 1:52 Y A 8
L2 2:48 - A 7

Member Port Rx Sel Mux Actor Partner

Port Priority State Logic State Flags Port


1:52 0 Current Selected Collect-Dist A-GSCD-- 3052

2:48 0 Defaulted Unselected Detached A-G---F- 0

These ports are all connected over fiber. I am not sure what defaulted means. But the defaulted action on both sides is Delete.

I guess my questions are what should I do to start troubleshooting? And what does Defaulted mean. I am trying to read through the concepts guide for more information but I seem to be missing something. Also what should be the Correct Defaulted setting?

My next troubleshooting steps that I came with was to first try and replace the fiber cable on both sides and if that does not work then try and replace the GBIC's. If this does not sound like a good next step could you point me in the right direction as to what is?


7 replies

Userlevel 6
Hi Josh,

From what I see in these outputs 1:52 is connected to 3:52 and 2:48 is connected to 4:52. The odd thing is 2:48 is showing up as Active while 4:52 is showing up as Ready. I know this may sound trivial but can we make sure that the connections are going to the right place?

If they are then you are on the right track as far as replacing the cable and GBIC just to make sure. Look into the "show port stat" and "show port utilization" output as well to see which way traffic is flowing.
Thanks Patrick, From what I can tell All the lights show active and they are connected. I am working with a Tech now who has been very helpful and he says that he sees the traffic but it is getting dropped on the other end. We are thinking about maybe disabling the port on one side and re-enabling that as maybe the first step.

We are also trying to Figure out what Defaulted -F means. Would you happen to know by chance?
Userlevel 5
If you don't have EDP enabled on the LAG ports, enable it and run the command show edp ports all. You should be able to see what ports on the switch are live, and what remote ports they are connected to. That's a good place to start

# show edp ports all
Port Neighbor Neighbor-ID Remote Age Num
Port Vlans
20 X460-24p 00:00:00:04:96:98:7d:96 1:20 58 1
22 X460-24p 00:00:00:04:96:98:7d:96 1:23 45 1
=============================================================================[/code]The Defaulted state of a LAG port occurs when it does not receive an LACPDU from the partner within the specified hello time, you can check the LACP counters on both switches and see if LACPDUs that are being sent from one switch are arriving on the other. Until the LAG is fully formed, you will most definitely see dropped data traffic.

Userlevel 7
Hi Josh,
Were you able to get this sorted out?
Not yet. I have to create a change ticket but I think we decided to do the following;

Disable port 3:52 and see if port 4:52 comes up
Add a port to the LAG on another slot and see if that comes up

o configure sharing 3:52 add ports (to remove, just change “add” to “delete”)

· Unconfigure the LAG and re-add it

o disable sharing 3:52 (be sure one of the ports is disabled or it will loop when you disable the LAG)

o enable sharing 3:52 grouping 3:52,4:52 lacp

o configure vlan add port 3:52 tagged (for each VLAN)

I was able to replicate the issue at my house and I was able to fix it by disabling both ports then re-enabling the master and then re-enabling the member so I will try this and see if it works.

Thanks Drew for the followup
The problem was resolved. I disabled the member port on the 7th floor switch and checked that both sides showed down. Then I re-enabled the port and instantly both ports came up with A-GSCD-- on both sides. Waited over night and checked again this morning. The Lag group still looks to be in working order.

Thanks to Everyone here and to Brandon the engineer that I worked with on the support ticket. It was very much appreciated.
Kawawa I will look more into the edp info that you provided. That looks extremely helpful.