Ospf is not filling route table


Userlevel 2
I've been using a switch extreme x460 24pt in my lab, and i'm setting up OSPF, so when the ospf is running and up, the sw is not able to filled the route table with the routes received from the another router as if they doesn't exchange router table.

So weird, nevertheless i'm using the trial license because this scene is a lab.

However follow a few output commands below from router and switch, where there is a simple configurations in both, cause i'm just try.

from router A(quagga)
"ospfd# sh ip ospf neighbor "

" Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL"
"192.168.3.89 1 Full/Backup 31.961s 192.168.3.89 eth0:192.168.3.29 0 0 0"

"router ospf"
" ospf router-id 10.10.200.2"
" redistribute connected"
" redistribute static"
" network 10.10.200.2/32 area 0.0.0.0"
" network 192.168.3.0/24 area 0.0.0.0"

From switch Extreme(in this switch i'm running a trial license)

enable ospf
configure ospf add vlan lo1 area 0.0.0.0 passive
configure ospf add vlan MK_01 area 0.0.0.0 link-type point-to-point
configure ospf add vlan OP01 area 0.0.0.0 link-type point-to-point
"====="
sh ospf neighbor
"Neighbor ID Pri State Up/Dead Time Address Interface"
" BFD Session State "
==========================================================================================
"10.10.200.2 1 FULL /DR 00:00:20:47/00:00:00:10 192.168.3.29 OP01 "

"======
sh licenses
Enabled License Level:
30 days Trial - expires in 30 days
" ====="
sh ospf lsdb

AS External LSAs
Link State ID Adv Router Seq# Age Chksum Tag
-------------------------------------------------------------
192.168.4.0 10.10.200.2 0x80000003 449 0x95da 0
192.168.4.0 192.168.4.229 0x80000002 2298 0x40bc 0

Router LSAs for area 0.0.0.0
Link State ID Adv Router Seq# Age Chksum #Links
-------------------------------------------------------------
10.10.200.2 10.10.200.2 0x80000005 1307 0x7109 2
172.16.254.255 172.16.254.255 0x80000008 2239 0xaa2b 3
192.168.3.89 192.168.3.89 0x80000004 1284 0x2f96 3

Network LSAs for area 0.0.0.0
Link State ID Adv Router Seq# Age Chksum
-------------------------------------------------------------
192.168.3.29 10.10.200.2 0x80000004 1308 0x4505

Thanks you for your help me.

BRegards
Welisson

2 replies

Welisson,

If the OSPF link type doesn't match, i.e. one side configured as point to point and other side as Braodcast will lead to this issue. Could you make sure that the link-type is same on both the neighbors.
Userlevel 2
Balaji wrote:

Welisson,

If the OSPF link type doesn't match, i.e. one side configured as point to point and other side as Braodcast will lead to this issue. Could you make sure that the link-type is same on both the neighbors.

Hello Balaji,

Thank you for replying, and you are right i wasn't pay attention in this information, but it is weird because the section was establishing, i think it shouldn't be established once the network type was incompatible between them.

Reply