Header Only - DO NOT REMOVE - Extreme Networks

ospf stuck in init state


ospf v2 created on 2 BD switches for communication between BD switch and Node. Point to point works okay on one BD, but didn't work on other BD side stack its in INIT stage while on Node end its is completely down. All configuration verified and observed to be okay and all perameter check/match
done but nothing work.

The os realease on BD is 15.1.3.4 patch 1-8

Switch02

=======

enable ospf
enable ospf export direct cost 10 type ase-type-2
enable ospf export static cost 10 type ase-type-2

create ospf area 10.0.0.8
configure ospf area 10.0.0.8 nssa summary stub-default-cost 10

configure ospf add vlan Y area 10.0.0.8
configure ospf vlan Y timer 10 40 10 40 40



DSNSW02.2 # show ospf neighbor



Neighbor ID Pri State Up/Dead Time Address Interface

Y.Y.Y.Y 1 INIT /DROTHER 01:22:34:44/00:00:00:10 Y.Y.Y.Y Y

Siwtch01

=====

enable ospf
enable ospf export direct cost 10 type ase-type-2
enable ospf export static cost 10 type ase-type-2

create ospf area 10.0.0.8
configure ospf area 10.0.0.8 nssa summary stub-default-cost 10

configure ospf add vlan X area 10.0.0.8
configure ospf vlan X timer 10 40 10 40 40



* SW01.2 # show ospf neighbor



Neighbor ID Pri State Up/Dead Time Address Interface

X.X.X.X 1 FULL /BDR 01:22:55:08/00:00:00:06 X.X.X.X X

4 replies

Userlevel 1
I had an issue where one of my switches was stuck in init stage and I bounced the port and it came back up.
Userlevel 7
Hi waqas,

did you check the license on both switches?

You might need to unconfigure and disable OSPF, and then add the configuration from the start. Be sure to configure both side with identical settings, either both with point-to-point interfaces or both without. Please ensure that no switch is configured with an OSPF priority of 0, but without point-to-point (this requires a core license).

Erik
Hi Erik,

We have 2 more ospf areas on same switches and they are working fine, the only issue is with 3rd OSPF on switch02 and on switch01 all 3 ospf areas are working fine, below are the areas define on both the switches.

create ospf area 10.0.0.1
configure ospf area 10.0.0.1 stub summary stub-default-cost 10
create ospf area 10.0.0.2
configure ospf area 10.0.0.2 stub summary stub-default-cost 10

create ospf area 10.0.0.8
configure ospf area 10.0.0.8 nssa summary stub-default-cost 10

Waqas
Userlevel 4
Delete and re-create the vlan that the OSPF neighborship should be established on with the other side. Moreover i could see currently the os realease on BD is 15.1.3.4 patch 1-8 as per your last conversation here. This is not the supported version at all for the Black Diamond device at present to consider.

Moving forward you can always upgrade these devices to the latest recommended 16.1.3.6 release for their latest patch if possible.

Reply