Question

OSPF Troubleshooting quesitons..


The problem right now is that our outbound traffic is only using one of our many MPLS pipes. And i reckon this is because there is only one advertising router for those networks.

1. We have multiple ISP routers redistributing routes (they say they do) into our OSPF network. But on our internal routers i only see one entry in the LSDB. Is this normal ..or is our ISP lying

2. The VLANs added to EAPS are also the ones with interfaces on OSPF.. so would EAPS be preventing OSPF LSAs ?


15 replies

Userlevel 4
You should see one routes in the routing table but multiple in LSDB. EAPS should not prevent OSPF LSA untill and unless the port is in active for the EAPS domain.

I
Simit,

Thanks for the reply, can you clarify on the point you made " EAPS should not prevent OSPF LSA untill and unless the port is in active for the EAPS domain."...

port is "in active" ? as in ?
Userlevel 2
EAPS will not block any LSAs. Can you post a snippet of your OSPF config maybe ?
andreas wrote:

EAPS will not block any LSAs. Can you post a snippet of your OSPF config maybe ?

show configuration ospf#
# Module ospf configuration.
#
configure ospf routerid 172.20.11.1
enable ospf
enable ospf export static Export_Statics
create ospf area 0.0.0.15
create ospf area 0.0.1.0
configure ospf add vlan XYZ area 0.0.0.0 passive
configure ospf add vlan XYZ-ABC area 0.0.0.0 passive
configure ospf vlan Default priority 0
configure ospf add vlan SITE1-SITE2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan DATA area 0.0.0.0
configure ospf add vlan ROUTER-1-2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan QWERTY area 0.0.0.0 passive
andreas wrote:

EAPS will not block any LSAs. Can you post a snippet of your OSPF config maybe ?

show configuration ospf#
# Module ospf configuration.
#
configure ospf routerid 172.20.11.1
enable ospf
enable ospf export static Export_Statics
create ospf area 0.0.0.15
create ospf area 0.0.1.0
configure ospf add vlan XYZ area 0.0.0.0 passive
configure ospf add vlan XYZ-ABC area 0.0.0.0 passive
configure ospf vlan Default priority 0
configure ospf add vlan SITE1-SITE2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan DATA area 0.0.0.0
configure ospf add vlan ROUTER-1-2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan QWERTY area 0.0.0.0 passive
andreas wrote:

EAPS will not block any LSAs. Can you post a snippet of your OSPF config maybe ?

how to config connect to cisco "cisco have > key chain "
show configuration ospf#
# Module ospf configuration.
#
configure ospf routerid 172.20.11.1
enable ospf
enable ospf export static Export_Statics
create ospf area 0.0.0.15
create ospf area 0.0.1.0
configure ospf add vlan XYZ area 0.0.0.0 passive
configure ospf add vlan XYZ-ABC area 0.0.0.0 passive
configure ospf vlan Default priority 0
configure ospf add vlan SITE1-SITE2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan DATA area 0.0.0.0
configure ospf add vlan ROUTER-1-2 area 0.0.0.0 link-type point-to-point
configure ospf add vlan QWERTY area 0.0.0.0 passive
Userlevel 2
So vlan SITE1-SITE2 is the area you have towards the ISP ?

How do your show ospf neig look like today ?
andreas wrote:

So vlan SITE1-SITE2 is the area you have towards the ISP ?

How do your show ospf neig look like today ?

the site-2 is two cities linked by a LAN extension.

The ISP link is Router-1-2
sh ospf neighbor
Neighbor ID Pri State Up/Dead Time Address
172.21.2.1 1 FULL /DR 245:10:24:21/00:00:00:02 172.21.2.1

Im wondering EAPS has nothing to do with LSDB entries. IF my extreme switch is connected directly to the ISP CE router, then by default that router should be advertising all routes that are behind it in the MPLS. But the LSDB of the extreme router connected to the ISP CE router doesn't have any advertisements coming form that particular CE router.
Userlevel 4
Can you provide "show version" command output and your contact phone number to discuss you about this issue?
Sumit Tokle wrote:

Can you provide "show version" command output and your contact phone number to discuss you about this issue?

Sumit, i have your email from a previous support ticket that you helped me on, so do you mind if i email you in case of doubts regarding this.. As of now i have narrowed it down to the ISP not advertising the routes. So i will be asking them to forward me the configuration of their CE router. Unless you think it could be a bug ?

any known bugs for OSPF in exos 12.5 ?
Userlevel 4
Sumit Tokle wrote:

Can you provide "show version" command output and your contact phone number to discuss you about this issue?

go ahead ..
Userlevel 4
Sumit Tokle wrote:

Can you provide "show version" command output and your contact phone number to discuss you about this issue?

what is your scenario?
Single home? (one router connected to another single ISP's router)(BGP not recommended)
Dual Home? (One or Multiple router connected to sing ISP routes)((BGP not recommended))
Multihoming? (Connected to two or more ISP?)
Dual Multihomming (Similar to Multihoming but with redundant link)
Sumit Tokle wrote:

Can you provide "show version" command output and your contact phone number to discuss you about this issue?

core router 1 ---> edge router 1 ---> ISP router 1 (MPLS)
core router 1 ---> edge router 2 ---> ISP router 2 (MPLS)

So our network has two ISP routers connected at each site, yet we only see one entry for each advertised route in the lsdb.

will send you an email with details of issue and network diagram.
Userlevel 4
Sumit Tokle wrote:

Can you provide "show version" command output and your contact phone number to discuss you about this issue?

It was nice speaking with you Yuvi.

Reply