Ping to the internet from virtual exos doesn't work


Hi,

I am new user of Extreme products, so i installed EXOS for virtual lab but when i did all the configuration (vlan, ipaddress, port) , i couldn't ping any website or server in the internet , i can't even ping my default gateway .So, can someone help me to resolve this problem?

Thank you

28 replies

Userlevel 1
did you configure the default gateway?

configure iproute add default [i]
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

i did the configuration of default gateway but it still not responding

Userlevel 6
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

Can you please confirm if the vlan is up (port link-up)? show iproute command will show if the route is up.

You have also to make sure you mapped the right interface into the VBOX or VMWare.
Userlevel 1
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

It looks like you're using a VM. What are you using, vbox, vmware (workstation or esxi)? what do you see when you run the command show ports no-refresh?
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

I am using vbox. and here the result of the command

Userlevel 1
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

can you also send the output to the configs that henrique requested?
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

Userlevel 6
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

Is 192.168.1.254 directly connected to vlan "default" port 1? What's that device connected to port 1?

If that device is not a FW and would respond to ICMP requests, I believe the issue is related to VBOX port map.
Darren Saliva wrote:

did you configure the default gateway?

configure iproute add default [i]

no i want access internet via wireless network
Userlevel 2
try
ping vr vr-default x.x.x.x
Michal Rz wrote:

try
ping vr vr-default x.x.x.x

no it doesn't work
Userlevel 6
Hi, please provide more details such as simple topology with IPs and the outputs below:

show config vlan
show config rtmgr
show iproute
Henrique wrote:

Hi, please provide more details such as simple topology with IPs and the outputs below:

show config vlan
show config rtmgr
show iproute

I just try to connect the internet from my virtual machine
Userlevel 7
Hi,

What hypervisor are you running this VM in? What does the virtual network config look like in the hypervisor?

Is the virtual network with 192.168.1.254 on it attached to port 1 on the VM?

Also, if you have Wireshark installed, can you try taking a packet capture on your PCs adapter that's connected to the virtual network? This way we can see if the traffic is leaving the VM and hitting the vSwitch. (This is assuming that your PC is 192.168.1.254)

-Brandon
Brandon Clay wrote:

Hi,

What hypervisor are you running this VM in? What does the virtual network config look like in the hypervisor?

Is the virtual network with 192.168.1.254 on it attached to port 1 on the VM?

Also, if you have Wireshark installed, can you try taking a packet capture on your PCs adapter that's connected to the virtual network? This way we can see if the traffic is leaving the VM and hitting the vSwitch. (This is assuming that your PC is 192.168.1.254)

-Brandon

VirtualBox is the hypervisor,u mean cthe virtual network config by this



i will try to make a capture of the traffic
Userlevel 7
Brandon Clay wrote:

Hi,

What hypervisor are you running this VM in? What does the virtual network config look like in the hypervisor?

Is the virtual network with 192.168.1.254 on it attached to port 1 on the VM?

Also, if you have Wireshark installed, can you try taking a packet capture on your PCs adapter that's connected to the virtual network? This way we can see if the traffic is leaving the VM and hitting the vSwitch. (This is assuming that your PC is 192.168.1.254)

-Brandon

The first adapter in VirtualBox is the management port of the EXOS VM. The "front panel" ports of the VM are the VirtualBox adapters starting at 2.
Userlevel 5
If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

i did it

Userlevel 6
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

Hi Ala,

Could you please try configuring your Adapter 2 instead of Adapter 1? I guess that your adapter 1 might be representing the EXOS Mgmt port.

Also, please share the output below:

show vlan
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html


here the result of sh vlan
Userlevel 7
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

Your setup connects the EXOS VMs management port (VLAN Mgmt, virtual router VR-Mgmt) to your computers Wi-Fi adapter. If you want to ping using that port, you need to specify the virtual router VR-Mgmt:
ping vr VR-Mgmt 8.8.8.8[/code]
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

Do you mean i should assign the IP 8.8.8.8 to the Mgmt vlan ?
Userlevel 7
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

No, 8.8.8.8 is the well know IP address of Google's primary public DNS server. Thus it is a common IP address for Internet connectivity tests.

Since you want to reach the Internet, you need to configure an IP address on the Mgmt VLAN, that is allowed to access the Internet from your computer.
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html




i try it
Userlevel 7
Kawawa wrote:

If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html

I am sorry, I forgot to mention that you need to set a default route as well:
configure iproute add default 192.168.1.1 vr VR-Mgmt [/code]The above assumes that 192.168.1.1 is the default gateway for your network. Please adjust if necessary.

Reply