Port cannot belong to VLAN and a VMAN at the same time.


Trying to configure QinQ solution between two extreme switches and im facing an issue when trying to make one of the ports untagged:

| Error: 8: Port cannot belong to VLAN and a VMAN at the same time.|

This port is not configured in any VLAN or VMAN as Untagged

This issue a get only in one SW, in the other one im able to configured the port as untagged.

The only difference between SW are the Image version running. But im not sure if that is the case?

19 replies

Userlevel 1
Can you share the "show port 8 information detail"?
Hi,

Please find below the output. Names have been removed.

# show ports 8 information detail Port: 8(removed-name):
Virtual-router: VR-Default
Type: UTP
Random Early drop: Unsupported
Admin state: Enabled with auto-speed sensing auto-duplex
Link State: Active, 1Gbps, full-duplex
Link Counter: Up 10 time(s)

VLAN cfg:
Name: removed-name, 802.1Q Tag = 200, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 201, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 202, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 213, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 214, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 212, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 215, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 216, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 223, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 224, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 225, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 227, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 228, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 229, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 236, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 237, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 414, MAC-limit = No-limit, Virtual router: VR-Default
Name: removed-name, 802.1Q Tag = 230, MAC-limit = No-limit, Virtual router: VR-Default

STP cfg:

Protocol:
Trunking: Load sharing is not enabled.
EDP: Enabled
ELSM: Disabled
Learning: Enabled
Unicast Flooding: Enabled
Multicast Flooding: Enabled
Broadcast Flooding: Enabled
Jumbo: Enabled, MTU= 9216
Link up/down SNMP trap filter setting: Enabled
Egress Port Rate: No-limit
Broadcast Rate: No-limit
Multicast Rate: No-limit
Unknown Dest Mac Rate: No-limit
QoS Profile: None configured
Ingress Rate Shaping : Unsupported
Ingress IPTOS Examination: Disabled
Ingress 802.1p Examination: Enabled
Ingress 802.1p Inner Exam: Disabled
Egress IPTOS Replacement: Disabled
Egress 802.1p Replacement: Disabled
NetLogin: Disabled
NetLogin port mode: Port based VLANs
Smart redundancy: Enabled
Software redundant port: Disabled
auto-polarity: Enabled
Userlevel 6
Can you please share the EXOS image being used, switch model, show vlan and show vman outputs?
Henrique wrote:

Can you please share the EXOS image being used, switch model, show vlan and show vman outputs?

show version

Switch : 800163-00-08 0938G-80032 Rev 8.0 BootROM: 1.0.3.5 IMG: 12.1.2.17
XGM2-1 :

Image : ExtremeXOS version 12.1.2.17 v1212b17-patch1-10 by release-manager
on Thu Jan 8 21:02:01 PST 2009
BootROM : 1.0.3.5

#############################################

show switch

System Type: X450a-48t

SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled

Boot Time: Fri Aug 8 16:43:00 2014
Boot Count: 5
Next Reboot: None scheduled
System UpTime: 573 days 4 hours 58 minutes 39 seconds

Current State: OPERATIONAL
Image Selected: secondary
Image Booted: secondary
Primary ver: 12.4.1.7
Secondary ver: 12.1.2.17

Config Selected: primary.cfg
Config Booted: primary.cfg

primary.cfg Created by ExtremeXOS version 12.1.2.17
198565 bytes saved on Thu Mar 3 19:45:38 2016

#############################################

show vlan
---------------------------------------------------------------------------------------
Name VID Protocol Addr Flags Proto Ports Virtual
Active router
/Total
---------------------------------------------------------------------------------------
VLAN_NAME_REMOVED 414 ------------------------------------------- ANY 2 /3 VR-Default
VLAN_NAME_REMOVED 1 ------------------------------------------- ANY 0 /0 VR-Default
VLAN_NAME_REMOVED 224 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 225 ------------------------------------------- ANY 4 /6 VR-Default
VLAN_NAME_REMOVED 203 ------------------------------------------- ANY 2 /2 VR-Default
VLAN_NAME_REMOVED 213 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 215 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 212 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 214 ------------------------------------------- ANY 2 /3 VR-Default
VLAN_NAME_REMOVED 227 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 230 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 229 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 228 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 4095 ------------------------------------------- ANY 1 /1 VR-Mgmt
VLAN_NAME_REMOVED 202 -----------T----------- ANY 3 /5 VR-Default
VLAN_NAME_REMOVED 290 ------------------------------------------- ANY 2 /2 VR-Default
VLAN_NAME_REMOVED 223 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 200 -------------------------------T----------- ANY 3 /5 VR-Default
VLAN_NAME_REMOVED 201 -------------------------------T----------- ANY 3 /5 VR-Default
VLAN_NAME_REMOVED 236 -------------------------------T----------- ANY 3 /5 VR-Default
VLAN_NAME_REMOVED 237 -------------------------------T----------- ANY 3 /5 VR-Default
VLAN_NAME_REMOVED 216 ------------------------------------------- ANY 2 /4 VR-Default
VLAN_NAME_REMOVED 281 -------------------------------T----------- ANY 1 /1 VR-Default
VLAN_NAME_REMOVED 280 -------------------------------T----------- ANY 2 /2 VR-Default
---------------------------------------------------------------------------------------
Flags : (C) EAPS Control VLAN, (d) NetLogin Dynamically created VLAN,
(D) VLAN Admin Disabled, (E) ESRP Enabled, (f) IP Forwarding Enabled,
(F) Learning Disabled, (i) ISIS Enabled, (L) Loopback Enabled,
(l) MPLS Enabled, (m) IPmc Forwarding Enabled,
(M) Translation Member VLAN or Subscriber VLAN, (n) IP Multinetting Enabled,
(N) Network Login VLAN, (o) OSPF Enabled, (O) Flooding Disabled, (p) PIM Enabled,
(P) EAPS protected VLAN, (r) RIP Enabled, (R) Sub-VLAN IP Range Configured,
(s) Sub-VLAN, (S) Super-VLAN, (t) Translation VLAN or Network VLAN,
(T) Member of STP Domain, (V) VPLS Enabled, (v) VRRP Enabled

#############################################

show vman
---------------------------------------------------------------------------------------
Name VID Protocol Addr Flags Proto Ports Virtual
Active router
/Total
---------------------------------------------------------------------------------------
NAMES_REMOVED 324 -------------------- ----------------------- ANY 1 /1 VR-Default
---------------------------------------------------------------------------------------
Flags : (a) Learning Domain (C) EAPS Control vlan, (E) ESRP Enabled,
(f) IP Forwarding Enabled, (F) Learning Disabled, (i) ISIS Enabled,
(I) IP Forwarding lpm-routing Enabled, (L) Loopback Enabled,
(m) IPmc Forwarding Enabled, (n) IP Multinetting Enabled, (N) Network LogIn vlan,
(o) OSPF Enabled, (O) Flooding Disabled, (p) PIM Enabled,
(P) EAPS protected vlan, (r) RIP Enabled, (T) Member of STP Domain,
(v) VRRP Enabled, (B) 802.1ah Backbone VMAN, (S) 802.1ah Service VMAN

Total number of vman(s) : 1
Userlevel 7
Hi Drin,

If a port has any VLANs on it, you cannot add it untagged to a VMAN. This is because adding a port untagged to a VMAN assumes that single tagged traffic will come in, and the VMAN will add its tag as a second 802.1q tag.

-Brandon
Hi Brandon,

I as explained in the beginning im able to do port untagged in the other SW and working perfectly.

But in this sw im unable to do it and the error you already have it in description
Please see additional information from other SW when im able to add port as untagged

show ports 3 information detail
Port: 3(name):
Virtual-router: VR-Default
Type: UTP
Random Early drop: Unsupported
Admin state: Enabled with auto-speed sensing auto-duplex
Link State: Active, 1Gbps, full-duplex
Link Counter: Up 8 time(s)

VLAN cfg:
Name: VLAN_NAMES 802.1Q Tag = 236, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 237, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 238, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 241, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 325, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 347, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 205, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 600, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 11, MAC-limit = No-limit, Virtual router: VR-Default
Name: VLAN_NAMES 802.1Q Tag = 12, MAC-limit = No-limit, Virtual router: VR-Default
Name: VMAN_NAME Internal Tag = 324, MAC-limit = No-limit, Virtual router: VR-Default

STP cfg:

Protocol:
Name: VMAN_NAME Protocol: ANY Match all protocols.
Trunking: Load sharing is not enabled.
EDP: Enabled
ELSM: Disabled
Ethernet OAM: Disabled
Learning: Enabled
Unicast Flooding: Enabled
Multicast Flooding: Enabled
Broadcast Flooding: Enabled
Jumbo: Enabled, MTU= 9216
Flow Control: Rx-Pause: Enabled Tx-Pause: Disabled
Link up/down SNMP trap filter setting: Enabled
Egress Port Rate: No-limit
Broadcast Rate: No-limit
Multicast Rate: No-limit
Unknown Dest Mac Rate: No-limit
QoS Profile: None configured
Ingress Rate Shaping : Unsupported
Ingress IPTOS Examination: Disabled
Ingress 802.1p Examination: Enabled
Ingress 802.1p Inner Exam: Disabled
Egress IPTOS Replacement: Disabled
Egress 802.1p Replacement: Disabled
NetLogin: Disabled
NetLogin port mode: Port based VLANs
Smart redundancy: Enabled
Software redundant port: Disabled
auto-polarity: Enabled

############################

configure vman VMAN_NAME add ports 47 tagged
configure vman VMAN_NAME add ports 3 untagged
Userlevel 6
are both switches 450's ?
SW that im able to configure port UNTAGGED
show switch

System Type: X450a-48t

SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled

Current Time: Sat Mar 26 18:00:04 1921
Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time: Sat Mar 6 08:49:23 1920
Boot Count: 8
Next Reboot: None scheduled
System UpTime: 385 days 9 hours 10 minutes 41 seconds

Current State: OPERATIONAL
Image Selected: primary
Image Booted: primary
Primary ver: 12.4.1.7
Secondary ver: 12.4.1.7

Config Selected: primary.cfg
Config Booted: primary.cfg

primary.cfg Created by ExtremeXOS version 12.4.1.7
212814 bytes saved on Sat Mar 26 15:09:46 1921

show version

Switch : 800163-00-05 0802G-80203 Rev 5.0 BootROM: 1.0.2.2 IMG: 12.4.1.7
XGM2-1 : N/A N/A Rev 0.0

Image : ExtremeXOS version 12.4.1.7 v1241b7 by release-manager
on Sat Mar 13 02:36:57 EST 2010
BootROM : 1.0.2.2

############################################

SW that im unable to configure port UNTAGGED

show switch

System Type: X450a-48t

SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled

Current Time: Thu Mar 3 22:36:57 2016
Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time: Fri Aug 8 16:43:00 2014
Boot Count: 5
Next Reboot: None scheduled
System UpTime: 573 days 5 hours 53 minutes 57 seconds

Current State: OPERATIONAL
Image Selected: secondary
Image Booted: secondary
Primary ver: 12.4.1.7
Secondary ver: 12.1.2.17

Config Selected: primary.cfg
Config Booted: primary.cfg

primary.cfg Created by ExtremeXOS version 12.1.2.17
198565 bytes saved on Thu Mar 3 19:45:38 2016

show version

Switch : 800163-00-08 0938G-80032 Rev 8.0 BootROM: 1.0.3.5 IMG: 12.1.2.17
XGM2-1 :

Image : ExtremeXOS version 12.1.2.17 v1212b17-patch1-10 by release-manager
on Thu Jan 8 21:02:01 PST 2009
BootROM : 1.0.3.5
Userlevel 6
From the 12.1 concepts guide.... 450's are a bit different for that code rev

■ On Summit X150, X250e, X350, X450a, and X450e series switches, and on the BlackDiamond 8800a-series, c-series, and e-series modules, you can configure vMANs and VLANs on the same
module or on the same stand-alone switch regardless of the vMAN ethertype. However, vMANs
and VLANs cannot be configured on the same physical port, unless you change the vMAN
ethertype to 0x8100.
■ On Summit 250e, 450a, and 450e family switches and the BlackDiamond 8800 a-series, c-series,
and e-series modules, you can configure vMANs and VLANs on the same port as follows:
■ Tagged and untagged vMANs on the same port (vMAN ethertype = 0x8100)
■ Tagged vMANs and tagged VLANs on the same port (vMAN ethertype = 0x8100)
■ Tagged vMANs and untagged VLANs on the same port
NOTE
Userlevel 6
You can get into trouble changing ethertype if you have active vmans so need to dig and think this out... may be best to get both of them on common code first ....
So this VMAN configuration in those SW is new beside working configuration for other VLAN's

So what i did it first was as below:

enable jumbo-frame ports all

configure vman ethertype 0x8100

then configure the VMAN in both SW

Also tried to remove and configure again. Same situation.
The only difference between two SW is as i mentioned in primary description:

SW1: Image version 12.4.1.7 (working untagged port)
SW2: Image version 12.1.2.17 (not working untagged port)
Userlevel 6
there is a table in concepts guide 12.4.2 that shows what switches and port vlan, vman page 515 ... talks about 450 and what you can and can't do
I was through documentation but couldn't find something related to my issue.

I will try to make SW2 same image version as SW1 and will update the post.

Thanks for your contribution
Userlevel 7
Drin wrote:

I was through documentation but couldn't find something related to my issue.

I will try to make SW2 same image version as SW1 and will update the post.

Thanks for your contribution

Hi Drin, did upgrading the switch help resolve your problem?
Drin wrote:

I was through documentation but couldn't find something related to my issue.

I will try to make SW2 same image version as SW1 and will update the post.

Thanks for your contribution

Hi,

I still didnt get a chance to upgrade the switch.

I will update thread once done.
Userlevel 7
Drin wrote:

I was through documentation but couldn't find something related to my issue.

I will try to make SW2 same image version as SW1 and will update the post.

Thanks for your contribution

No worries. Just wanted to check.
Hi all,
First i want to thank you for the support.

Since i have a live network i was unable to perform the upgrade in image and i was wondering if someone can advice me for any other solution.

So what i need is QinQ solution.

SW-01
Port-01-Local(Multiple VLAN's)
Port-02-Outgoing(Fixed Single VLAN-324)

SW-02
Port-01-Local(Multiple VLAN's)
Port-02-Outgoing(Fixed Single VLAN-324)

Is there any possibilities rather then using VMAN to be able to communicate VLANs related to port 1 in both SW.

Reply