Header Only - DO NOT REMOVE - Extreme Networks
Question

Printer's switch ports going down when printer enters power save mode

  • 15 January 2020
  • 6 replies
  • 448 views

Userlevel 3

Hi!

Since the introduction of switches lacking the capability of half duplex, we see that printers (and probably other stuff) lose the ethernet link when the printer enters power save mode. This means that a printer cannot be manages and no status can be read from it during the power save mode. Looking back in the logs, we see that those same printers “flapped” between 1 G full duplex (FD) and 10 M HD when connected to X450e switches. With the X450-G2’s, they instead alternate between 1 G FD and no link. I think it’s safe to say that this is because the printer only advertises 10 M HD on the ethernet link auto negotiation when it is in power save mode and the switch cannot accept that, so the link is brought down.

One fix is to set the power save mode of the printer to a less aggressive setting, but that raises the sleep power from 0.9 W to 36 W. Putting a small consumer switch between the printer and switch (with a power draw of ~5 W) also solves the problem, but adds to maintenance and cost.

Does anyone else have this problem? Any info on how printer manufacturers tackle this problem?

/Fredrik


6 replies

Userlevel 6

The lack of half duplex support has caused us a bit of pain, mostly HVAC controllers and access control devices. 

I have not heard any complaints about this issue but thanks for sharing.

Userlevel 7

Did you ask the printer vendor why the device is only supporting 10HD in power save mode.

 

-Ron

Userlevel 3

Try setting the ip arp timeout on the switch to something like 5 min.  Had this problem with a couple of customers, printer would go to sleep and with a contain to vlan policy, wouldn’t wake up.  You didn’t mention policy, but this may help.  The ip arp setting helps keep the nic awake.

Userlevel 3

Ok, we can try the arp timeout, but since these switches only do L2 switching I don’t think it will do any good. Chaning the arp timeout on the firewalls (that do the routing) “ain’t gonna happen”... The printer gurus came up with a setting in the Canon printers that may solve the issue. It was called ”Compensate for Network Communication” and was on the same page as where you set the power save mode, so perhaps that’s the proper solution to it (for the printers anyway).

Thanks for all the replies!

/Fredrik

Thanks for all the replies!

Perhaps the problem is in the operating system? I changed more than 3 printers but I still could not connect them to a PC with Linux. I don’t know, maybe I’m doing something wrong, but it seems to me that the problem is that Linux is not compatible with printers. What do you think? I had a very old printer and I could not connect it and then I bought two new printers from the Canadian brand mrdepot.ca  and they were just amazing models but I also could not connect them to Linux, but they worked perfectly with Windows and I was completely confused .. Do you have any ideas ?? How can I solve this?

Reply