Header Only - DO NOT REMOVE - Extreme Networks

router-discovery dnssl in XOS broken?

Userlevel 5
I updated my BD8806s from 15.4.something to
I had this in my vlan config:
configure vlan DC_Techs router-discovery ipv6 add dnssl dc.local
configure vlan DC_Techs router-discovery ipv6 other-config-flag on
enable router-discovery ipv6 vlan DC_Techs
[/code]together with other things, like "add rdnss", "add prefix", etc, for IPv6 autoconfiguration

Suddenly - after the upgrade - I get errors in my logs like:
MSM-A: DNSSL Suffix Lookup failed for received Router Advertisement on vlan DC_Techs from fe80::204:96ff:fe8f:c9ea with a DNSSL suffix[/code]Yes, the "with a DNSSL suffix" *is* the last part of the line. It doesn't let me know what the suffix is that 'failed', but at this time I can only assume it's really an empty/blank/0 suffix 😞

Did a "show router-discovery DC_Techs" on my 8806s - looks fine, has "dc.local" showing on both.

Thought, "ok, let's just kill the dnssl entry" by doing:
# configure vlan DC_Techs router-discovery ipv6 delete dnssl dc.local
Error: The specified DNS Suffix is not configured[/code]Say what? OK, "configure.... delte dnssl all" - that worked.
Tried to add and delete by name - same thing.

I still have a pair of 8806s running where I can add and delete dnssl domain names by name just fine, and where neither errors happen at all, and "sh router-discovery vlan DC_Techs" yields the same output as on the BDs.

I know that Windows doesn't even understand IPv6's dnssl advertisements, and we usually hand-roll our Unix/Linux boxes, so it doesn't matter all that much - I just wanted to point out something rather odd.

Adding and deleting rdnss entries by specifying the addresses works just fine.


1 reply

Userlevel 7
Hi Frank,
I'd recommend that you open a case with GTAC for this one. It sounds like it will need further review so it can be sent to engineering.