Header Only - DO NOT REMOVE - Extreme Networks

Send 802.1p Value to Phone via LLDP


Userlevel 3
Hello - happy Friday!

I'm familiar with the command below which tells connected phones to use the 'Voice' Vlan and send voice packets with DSCP set to 46.

"configure lldp port [port] advertise vendor-specific med policy application voice vlan [vlan] dscp 46"

However it appears that XOS sends a dot1p value of 7 (network control traffic) to the phone by default and I can't find out how to change that - I want it set to 5 which is more commonly used for Voice.

Any ideas?

Many thanks.....

11 replies

configure dot1p type 5 qosprofile QPx
configure qosprofile QPx minbw 0 maxbw 100 port y:y

x=what Qosprofile you want to use for this.

Hopefully that is what you were wanting. 🙂
Userlevel 3
Hi, thanks but not quite - I want to send the voice policy to the phone via LLDP TLVs. You can configure the DSCP value but I can't see how to configure the dot1p.
Userlevel 6
Hi Stephen, did you add the LLDP MED capabilities TLV before configuring this TLV?

configure lldp ports advertise vendor-specific med capabilities
Userlevel 3
Yep...

enable lldp ports all
configure lldp port all advertise vendor-specific med capabilities
configure lldp port all advertise vendor-specific med policy application voice vlan VOICE dscp 46

.....but no option to amend the dot1p value sent in the policy?
Userlevel 6
If anyone else has a problem you can view this article. https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-LLDP-for-Extreme-switches...
Userlevel 3
# from the userguide : the L2 priority is derived from the vlan priority.
# assuming you want to assign 5 to the dot1p field, could you try the folloing to propagate the value of the dot1p value of 5 via LLDP MED,

Create qosprofile QP6
configure dot1p type 5 qp6

# assuming lldp is already configured
configure lldp ports [all | port_list] advertise vendor-specific med capabilities
configure lldp ports [all | port_list] advertise vendor-specific med policy application voice vlan voice dscp dscp_value 46

# configure the voice vlan to QP6 -> then the phone should hopefully start using dot1p=5
Configure vlan voice qosprofile qp6
Userlevel 3
Thanks JS, that seems to work!

Not sure at the moment if I'll implement it, as we're already using QP6 for all Voice traffic and QP4 for all Voice-Signalling traffic. So, if I mark the whole 'Voice' Vlan as QP6 both RTP & Signalling will be treated with the top priority, not necessarily something I'm looking for.

One question though, assuming the phone sends through a frame with a dot1p value of 7, what will the switch do with it under default configuration?
Userlevel 3
By default,

- all dot1p values but 7 are affected to QP1 ; 7 is affected to QP8

- dot1p examination is enabled

so taking classification precedence into consideration [table 91 - 16.1 userguide] and assuming you don't have any ACL- based QOS classification, I would suggest "dot1p=7 tagged" traffic should be sent to QP8.

the mapping table [dot1p <> QP] can be seen with "show dot1p"
Userlevel 3
...and as dot1p examination is turned on by default all voice RTP & signalling traffic is forwarded as the highest priority 'network control' traffic.

I'm surprised that vlans are set to advertise priority 7 by default, but thank you for the explanation, very helpful.
Userlevel 3
hello Stephen,

I would suggest that you check this with our GTAC.
I am not certain this is actually the expected behavior [assuming you have not associated the VLAN to any QOS profile]
Userlevel 1
I have this config on one of our Core switches "configure dot1p type 5 qosprofile QP7" but not on the other. I don't see any counters incrementing. I have seen some counters in the passed on QP7 but don't anymore. We don't have LLDP enabled nor have policies or acl's that include qp7 neither. I'm cleaning up my qosprofiles and can not delete qp7 because of the config. I'm not sure if its doing anything or not. Any help with this is appreciated. We have a shoretel phone system but as far as I can tell we're not using any qos.

Thank you

Reply