Header Only - DO NOT REMOVE - Extreme Networks
Question

Setting STP properly or disabling at all in MLAG setup

  • 8 November 2019
  • 6 replies
  • 642 views

Userlevel 2
Badge

Hello Guys,

 

I got a customer with MLAG’ed stacks as peers (X670-G2 and X460-G2 in each stack), where the edge switches are X440-G2 stacks, LAGged to both peers. So the whole environment is EXOS.

 

When I upgraded from 22.3 to 22.5 I got LAG uplink ports (master) on edge stacks set to blocked.

Command “debug vlan show vpif default 1:52” run on edge stack showed that STP was registered on the port.

 

Before the upgrade to 22.5 I didn’t setup STP in any way, although it was enabled by defalut AFAIK.

After the upgrade I tried to disable stpd on edge stacks, but it didn’t help.

 

As we had a downtime in production network,  there was no time for further troubleshooting and we have to revert to 22.3, which resulted in getting network up and working again.

 

I haven’t disabled STP on MLAG ports at MLAG peers when running 22.5, as I have no time.

I know that RSTP support for MLAG was introduced in ExtremeXOS 22.5 and that changed the way STP works in my setup.

 

Do you think disabling STP on MLAG ports at peers would help in this case ?

 

BEST REGARDS

Robert

 


6 replies

Hi Robert,

 

You are correct, the MLAG ports on the peer stacks and the LAG ports on the remote switch should not be in the blocking state. Removing these ports from all STP instances will likely fix your issue, however, I would double check your VLANs and their associated ports as wells as your STP config to ensure that there isn’t an additional loop in your network causing this issue.

 

For reference, see this article for STP requirements for an MLAG setup, this article for an example configuration, and this article for MLAG with RSTP limitations and configuration.

 

Regards,

Gabriel

Userlevel 2
Badge

Thank you, Gabriel !

 

So I am going to disable stp on MLAG ports:

disable stpd s0 ports <All_MLAG_ports_on_peers>

and on access stacks:

disable stpd s0 ports <Sharing_Master_port> 

 

Or even disable stp completely:

disable stpd 

on both MLAG peers and access stacks.

 

For loop protection I would rather use ELRP on MLAG peers.

Does it make sense ?

 

REGARDS 

Robert 

Robert,

 

That is correct. STP should be automatically disabled on the MLAG ports on the 2 peers when MLAG is enabled but double check and be sure to disable STP on the ISC link between the peers as well. I would advise against disabling STP entirely as an unknown loop in your network can cause a lot of issues so let’s isolate everything to this MLAG partition.

 

The ISC blocking filter will prevent a loop on the 3 node MLAG topology but if you need additional loop protection for the rest of you network you can use ELRP, RSTP for MLAG, or simply keep STP enabled on the rest of the network. Without knowing about the rest of your topology, I cannot give a more detailed suggestion.

 

Once STP is disabled on the interfaces involved in MLAG, check to see that the peer relation is up and that the LAG ports on the access switch up and not blocking. A problem at this point would likely be due to a bad MLAG config. As a quick reference, you can check this article for troubleshooting steps, or this article for configuration steps.

 

Also, here is an article for configuring RSTP for MLAG in case that fits your situation.

Thanks,
Gabriel

 

 

Userlevel 3

Or even disable stp completely:

disable stpd 

on both MLAG peers and access stacks.

 

That’s about the only proper way to configure spanning tree these days. What do you actually need STP for, really? I only ever recommend using it for access port loop detection and blocking but never on network links. There are so much better ways to build networks these days than to use STP. STP was invented 35 years ago!!!

/Fredrik

Userlevel 2
Badge

Fredrik,

 

To be honest I don’t need STP at all. 

I had never took it into consideration at network design stage, although not all network elements are under my control (like routing, for example).

It’s probably just the way EXOS sets STP up, when it’s enabled by default.

I don’t either think that this STP port blocking could be caused by some network loop, as we’ll have it regardless the EXOS is 22.3 or 22.5.

 

Thanks for all your thoughs, guys !

 

Robert

Userlevel 2
Badge

OK, guys - I disabled STP completely on both MLAG peers.

Now network is stable on EXOS 22.5.

 

Thanks,

Robert

Reply