Header Only - DO NOT REMOVE - Extreme Networks

"show config vlan" shows me some snmp config as well


Userlevel 1
This is on extremeos: why when I do "show config vlan" it shows me some snmp config as well ? weirdly it only seems to be disable snmp traps on ports ...

Like so:

code:
  Slot-1 es-x-k4a.1 # show config vlan
#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1:1-54,2:1-54,3:1-54,4:1-54
configure vr VR-Default add ports 1:1-54,2:1-54,3:1-54,4:1-54
configure vlan default delete ports 1:1-48,1:53-54,2:1-48,2:53-54,3:1-48,3:53-54 ,4:1-48,4:53-54
create vlan "ip-main"
configure vlan ip-main tag 100
create vlan "N3_Servers"
configure vlan N3_Servers tag 232
create vlan "pathology"
configure vlan pathology tag 229
create vlan "printer_vlan"
configure vlan printer_vlan tag 234
create vlan "purple"
configure vlan purple tag 176
create vlan "unarmed"
configure vlan unarmed tag 230
create vlan "vmgmt"
configure vlan vmgmt tag 101
create vlan "voice"
configure vlan voice tag 150
create vlan "wap05"
configure vlan wap05 tag 115
disable snmp traps port-up-down port 1:1
disable snmp traps port-up-down port 1:2
disable snmp traps port-up-down port 1:3
disable snmp traps port-up-down port 1:4
disable snmp traps port-up-down port 1:5
disable snmp traps port-up-down port 1:6
disable snmp traps port-up-down port 1:7
disable snmp traps port-up-down port 1:8
disable snmp traps port-up-down port 1:9
disable snmp traps port-up-down port 1:10
disable snmp traps port-up-down port 1:11
disable snmp traps port-up-down port 1:12
disable snmp traps port-up-down port 1:13
disable snmp traps port-up-down port 1:14
disable snmp traps port-up-down port 1:15
disable snmp traps port-up-down port 1:16
disable snmp traps port-up-down port 1:17
disable snmp traps port-up-down port 1:18
disable snmp traps port-up-down port 1:19
disable snmp traps port-up-down port 1:20
disable snmp traps port-up-down port 1:21
disable snmp traps port-up-down port 1:22
disable snmp traps port-up-down port 1:23
disable snmp traps port-up-down port 1:24
disable snmp traps port-up-down port 1:25
disable snmp traps port-up-down port 1:26
disable snmp traps port-up-down port 1:27
disable snmp traps port-up-down port 1:28
disable snmp traps port-up-down port 1:29
disable snmp traps port-up-down port 1:30
disable snmp traps port-up-down port 1:31
disable snmp traps port-up-down port 1:32
Rather annoying , probably another question for another time is why is snmp traps port-up-down even enabled by default when setting a trap receiver on the switch, that just generates a lot of noise.

3 replies

Userlevel 1
it does not want me to edit top fix up the output but the output is like so:

Slot-1 es-x-k4a.1 # show config vlan
#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1:1-54,2:1-54,3:1-54,4:1-54
configure vr VR-Default add ports 1:1-54,2:1-54,3:1-54,4:1-54
configure vlan default delete ports 1:1-48,1:53-54,2:1-48,2:53-54,3:1-48,3:53-54 ,4:1-48,4:53-54
create vlan "ip-main"
configure vlan ip-main tag 100
create vlan "N3_Servers"
configure vlan N3_Servers tag 232
create vlan "pathology"
configure vlan pathology tag 229
create vlan "printer_vlan"
configure vlan printer_vlan tag 234
create vlan "purple"
configure vlan purple tag 176
create vlan "unarmed"
configure vlan unarmed tag 230
create vlan "vmgmt"
configure vlan vmgmt tag 101
create vlan "voice"
configure vlan voice tag 150
create vlan "wap05"
configure vlan wap05 tag 115
disable snmp traps port-up-down port 1:1
disable snmp traps port-up-down port 1:2
disable snmp traps port-up-down port 1:3
disable snmp traps port-up-down port 1:4
disable snmp traps port-up-down port 1:5
disable snmp traps port-up-down port 1:6
disable snmp traps port-up-down port 1:7
disable snmp traps port-up-down port 1:8
disable snmp traps port-up-down port 1:9
disable snmp traps port-up-down port 1:10
disable snmp traps port-up-down port 1:11
disable snmp traps port-up-down port 1:12
disable snmp traps port-up-down port 1:13
disable snmp traps port-up-down port 1:14
disable snmp traps port-up-down port 1:15
disable snmp traps port-up-down port 1:16
disable snmp traps port-up-down port 1:17
disable snmp traps port-up-down port 1:18
disable snmp traps port-up-down port 1:19
disable snmp traps port-up-down port 1:20
disable snmp traps port-up-down port 1:21
disable snmp traps port-up-down port 1:22
disable snmp traps port-up-down port 1:23
disable snmp traps port-up-down port 1:24
disable snmp traps port-up-down port 1:25
disable snmp traps port-up-down port 1:26
disable snmp traps port-up-down port 1:27
disable snmp traps port-up-down port 1:28
disable snmp traps port-up-down port 1:29
disable snmp traps port-up-down port 1:30
disable snmp traps port-up-down port 1:31
disable snmp traps port-up-down port 1:32

https://community.extremenetworks.com/extreme
Userlevel 6
Hi Tino,

Because this is based on the port configuration this seems normal, I will test this to make sure. What version of EXOS are you running?
Userlevel 6
Hi Tino,

I think what you are seeing here is expected. The SNMP trap configuration is for each module (like VLAN or MPLS or OSPF etc.,) and not only related to the SNMP module.

since the port configuration is related to VLAN module, the ability to send SNMP traps for these up-down events come under the VLAN module.

Another example:

The SNMP traps for the MPLS is disabled by default.
If I enable these traps, I could see the following output.

* SW2.8 # ena snmp traps mpls * SW2.9 # sh conf mpls

#

# Module mpls configuration.

#

enable snmp traps mpls

Trap configuration is global for a switch and hence these configs are included in appropriate modules.

Hope this helps!

Reply