Show which vlans are tagged / untagged on a single port


When using the "show port [u] info detail" command, it will provide a list of all vlans assigned to a specific port. On an uplink port, the native vlan should be set as untagged, which with Extreme is the "default" vlan.

How does the output from this command distinguish between an untagged and tagged port?

Are untagged vlans labeled "Internal Tag = x" and tagged vlans as "802.1Q Tag = x"?

Is there a better command to use to find out which vlans are tagged or untagged on a single port?

6 replies

Userlevel 5
Hi Greg,

"Internal Tag = x" means untagged.
"802.1Q Tag = x" means tagged.

Thank you,
Brad
Userlevel 7
show ports vlan[/code] or show port vlan[/code]should give you what you're looking for.

For example:r2.5 # show ports 2 vlan Untagged Port /Tagged VLAN Name(s) -------- -------- ------------------------------------------------------------ 2 Untagged None Tagged r1_r2
[/code]
Userlevel 1
Hi Greg Hartze,

You can also do:
sh port vid[/code]
This command will show you the vlan ID on a given port

Regards
Gonçalo Reis
Userlevel 2
Ummm.... I never leave ports in the default VLAN, even if they are untagged. IMHO, using the default VLAN is poor practice *unless* the switch is being used as a private switch and not switching/routing any traffic off of the device.

WRT to your question: tagged ports will be reported as 802.1Q Tag = . Untagged ports are reported as "Internal Tag = "

WRT to your last question about a better method of showing which vlans are tagged/untagged on a single port: Try "show port vid"

Slot-1 b50ee2-1a-13.8 # show ports 1:53 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
1:53 Untagged None
Tagged 2240, 2241, 2242
Slot-1 b50ee2-1a-13.9 # [/code]
Thanks for the replies.
I've tested the "show port vid", "show ports vlan" and "show port vlan" commands but these command were not available for the summit switches I tried running EOS 15.7.1.4, 16.1.2.14 and 16.1.3.6... kept getting incomplete command errors.

But if the following is true, that will work. Thanks for the help!
"Internal Tag = x" means untagged.
"802.1Q Tag = x" means tagged.
I tried the above commands on an x440g2 switch running XOS v22.3.1.4 and these commands are available on this version so I assume they do not work on 15.x, 16.x but work on 21.x and 22.x XOS versions.

Reply