Header Only - DO NOT REMOVE - Extreme Networks

SNMPv3 config

  • 7 January 2014
  • 3 replies

Userlevel 4
Create Date: Oct 29 2012 4:11AM

Hello All,

I was hoping someone could help me with getting SNMPv3 setup. We are using Epicenter 7.0 (with SSH module) and I am trying to get SNMPv3 working. I have a Summit X460 stack setup with the SSH module installed. Here is what I am trying to do:

1. I want to disable using the default SNMP users, community and groups (SNMPv1, 2c and 3). I dont want the default public,private,initial groups to be used.
2. I want to define a new access, new group, new user, new community.
3. I want to setup SNMPv3 with AES256 and SHA1 (authpriv - USM).

I referred to the concepts guide and managed to get this setup (or so i thought). I setup a new target address and params as well. Now on Epicenter, I went to the modify comms settings for the stack and setup SNMP - all options given (password, authentication, cbs-des) etc. However it doesnt seem to be working. After configuring this in epicenter, i tried updating the stack to initiate a sync. it didnt work out.

to restore monitoring, i re-enabled snmpv1 and set that up. it worked like a charm. i appear to be missing a trick here. any help please. tks. (from Anush_Santhanam)

3 replies

Userlevel 4
Create Date: Oct 29 2012 8:36PM

Hello Excalibur

Would you be willing to give the switch config for the SNMPv3 settings?

It has been a while since I did it and will try and get it working and send you my commands.

P (from Paul_Russo)
Userlevel 4
Create Date: Oct 30 2012 1:52PM

Hello Excalibur

When you are adding the device to Epicenter what are you using for the privacy protocol? We currently do not support AES in Ridgeline. I am checking to see when it will be available. Right now we support DES which I have tested to work.

P (from Paul_Russo)
Userlevel 4
Create Date: Nov 1 2012 1:58AM

I did this yesterday. The difference being I was discovering a wireless controller using RIDGELINE3.1.

It works for me but the only encryption algorithm available is DES on Ridgeline. So i guess you would have to change your config on the switch in order to use this option.

I can help you further if required.

Arpit (from Arpit_Bhatt)