Stack only showing hal process for one node


Userlevel 2
  • New Member
  • 42 replies
We have a stack of 2 X450-G2-48P switches running 22.2.1.5. A while back one node failed as the hal process consumed 98% of the CPU and they switched roles. The master became the backup and vice versa. I am noticing today that the hal is consuming high memory and when I run "show process hal" it only reports one node

Slot-2 2 hal 457721
Slot-1 1 hal 519921

Stack Topology is a Ring
Active Topology is a Ring
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:a0:7e:c6 2 Active Master CA-
00:04:96:a0:7e:d6 1 Active Backup CA-

* Slot-2.10 # sh process hal
Card Process Name Version Restart State Start Time Group
-------------------------------------------------------------------------------------
Slot-1 hal 3.0.0.2 0 Ready Sat Apr 14 00:47:01 2018 EXOS

2 replies

Userlevel 6
I would suggest to upgrade, 22,2 is not the latest and quite a lot of problems are fixed in the latest 22.5.1 EXOS release.
Userlevel 2
Thanks for the reply, I looked at the release notes and I don't see any open issues that would affect me. TAC suggested I go to 21.1.4.4patch1-6 in early May but I don't want to go back in versions.

I didn't put the title on the above portion. This is when I run "show memory" it shows both nodes for the hal process.

Slot-2 2 hal 457721
Slot-1 1 hal 519921

Reply