Steps to use BootROM for reseting the admin account password for Summit X450e

  • 7 January 2014
  • 6 replies
  • 221 views

Userlevel 4
Create Date: Sep 17 2012 7:15AM

Hi All,

I forgot our Summit X450e admin account password. Can anybody explain the step for using BootROM for resetting the password.

Thanks (from Rajesh_Panchal)

6 replies

Userlevel 4
Create Date: Sep 17 2012 7:30AM

I don't want to erase switch configuration. I just want to reset my admin account password. (from Rajesh_Panchal)
Userlevel 4
Create Date: Oct 9 2012 8:14PM

you may load diagnostic linux with bootrom> boot 3 && then enable linux mode && find your config.cfg && open in vi text editor && correct your admin account with your hash (pass)

Be very carefull, you may kill your device with uncorrect steps!!!!! (from pacan4ik1_pacan4ik1)
Create Date: Oct 9 2012 8:14PM

you may load diagnostic linux with bootrom> boot 3 && then enable linux mode && find your config.cfg && open in vi text editor && correct your admin account with your hash (pass)

Be very carefull, you may kill your device with uncorrect steps!!!!! (from pacan4ik1_pacan4ik1)
Hi pacan4ik1_pacan4ik1,
I've tried your VI suggestion but have 2 problems with it.
1. I don't have a way of hashing a password to insert in the config file.
2. The file is read-only, so not able to save password change anyway

Any suggestiions? Also, any idea why BootRom > Config None or Default isn't working?

Thanks
Chris
Userlevel 4
Create Date: Oct 9 2012 8:14PM

you may load diagnostic linux with bootrom> boot 3 && then enable linux mode && find your config.cfg && open in vi text editor && correct your admin account with your hash (pass)

Be very carefull, you may kill your device with uncorrect steps!!!!! (from pacan4ik1_pacan4ik1)
Contact the TAC, they have some different way to reset the admin password...
Create Date: Oct 9 2012 8:14PM

you may load diagnostic linux with bootrom> boot 3 && then enable linux mode && find your config.cfg && open in vi text editor && correct your admin account with your hash (pass)

Be very carefull, you may kill your device with uncorrect steps!!!!! (from pacan4ik1_pacan4ik1)
Hi,
Thanks for the reply, appreciated.
I've got it working now, I was just being a bit impatient and not waiting for the AAA service to start. So login before that fails with admin/no p/w, but works after it starts 🙂. Note I still had to set config to none/default/anon in BootRom first.

###
(pending-AAA) login: [login here fails]
Authentication Service (AAA) on the master node is now available for login.
login: [login here successful]
####

Thanks
Chris
Userlevel 4
Create Date: Oct 9 2012 8:14PM

you may load diagnostic linux with bootrom> boot 3 && then enable linux mode && find your config.cfg && open in vi text editor && correct your admin account with your hash (pass)

Be very carefull, you may kill your device with uncorrect steps!!!!! (from pacan4ik1_pacan4ik1)
login at pending-AAA would always fails. You have to wait for normal login screen.

Reply