STP auto-bind not working as expected


Userlevel 5
I am currently working on a spanning tree example as per below. Its not how I would do it but the bit I can't workout is the auto-bind is enabled on this stp domain, yet when you look at all the ports on the Vlan that its bound too those ports are not being added as part of the stp domain - only port 48?

I've tried adding the following command to see if would make a difference but it didn't.

enable stpd STP-PS-Voice ports all[/code]

So I would expect auto-bind to automatically put every port that is vlan PS-Voice into the STP-PS-Voice domain, but its only putting in port 48?

Any ideas why?

Many thanks in advance

Switch1# show config stp | include STP-PS-Voice
create stpd STP-PS-Voice
configure stpd STP-PS-Voice mode dot1w
enable stpd STP-PS-Voice rapid-root-failover
configure stpd STP-PS-Voice default-encapsulation dot1d
enable stpd STP-PS-Voice auto-bind vlan PS-Voice
configure stpd STP-PS-Voice add vlan PS-Voice ports 48 pvst-plus
configure stpd STP-PS-Voice ports mode pvst-plus 48
configure stpd STP-PS-Voice ports cost auto 48
configure stpd STP-PS-Voice ports port-priority 128 48
configure stpd STP-PS-Voice ports link-type point-to-point 48
configure stpd STP-PS-Voice ports edge-safeguard disable 48
enable stpd STP-PS-Voice ports 48
enable stpd STP-PS-Voice[/code]

Switch1 # show vlan "PS-Voice"
VLAN Interface with name PS-Voice created by user
Admin State: Enabled Tagging: 802.1Q Tag 202
Description: None
Virtual router: VR-Default
IPv4 Forwarding: Disabled
IPv6 Forwarding: Disabled
IPv6: None
STPD: STP-PS-Voice(Enabled,Auto-bind)
Protocol: Match all unfiltered protocols
Loopback: Disabled
NetLogin: Disabled
QosProfile: None configured
Egress Rate Limit Designated Port: None configured
Flood Rate Limit QosProfile: None configured
Ports: 47. (Number of active ports=10)
Tag: 1, 2, 3, 4, 5, 6, 7,
*8, 9, *10, 11, 12, 13, *14,
15, 16, 17, *18, 19, 20, 21,
22, 23, 24, 25, *26, 27, 28,
29, *30, 31, 32, 33, *34, 35,
36, 37, 38, 39, 40, 41, *42,
43, *44, 45, 46, *48g
Flags: (*) Active, (!) Disabled, (g) Load Sharing port
(b) Port blocked on the vlan, (m) Mac-Based port
(a) Egress traffic allowed for NetLogin
(u) Egress traffic unallowed for NetLogin
(t) Translate VLAN tag for Private-VLAN
(s) Private-VLAN System Port, (L) Loopback port
(x) VMAN Tag Translated port
(G) Multi-switch LAG Group port
(H) Dynamically added by MVRP[/code]

Switch1 # show stpd "STP-PS-Voice" ports
Port Mode State Cost Flags Priority Port ID Designated Bridge
48* PVST+ FORWARDING 18000 eRppaw---- 128 8030 10:00:00:04:96:35:0e:6a[/code]

8 replies

Userlevel 4
Hey Martin,

Did you add the ports to the vlan before configuring STP? I believe the auto-bind feature will only take effect on new ports added into a vlan after STP is configured.

Can you give that a shot and let me know the results?

Thanks!
Userlevel 5
Hi Joe,

Thanks for posting.

Haven't personally configured this switch, just working on rectifying a few configuration issues. Just put in the following commands but it doesn't seem to have any effect:

Switch1 # configure vlan "PS-Voice" delete ports 1
Switch1 # configure vlan "PS-Voice" add ports 1 tagged
Switch1# show stpd "STP-PS-Voice" ports
Port Mode State Cost Flags Priority Port ID Designated Bridge
48* PVST+ FORWARDING 18000 eRppaw---- 128 8030 10:00:00:04:96:35:0e:6a

Total Ports: 1

[/code]

Many thanks.
Userlevel 4
Thanks for the information Martin. Can you please tell me what platform and software version you are running on? I will run a quick replication locally in my lab.
Userlevel 5
Its a summit X440-48p, running firmware 15.2.2.7 patch1-6.

Thanks.
Userlevel 4
Martin,

I did not see that auto-bind has been enabled for the STP-PS-Voice domain.

Can you confirm with the show stpd STP-PS-Voice

The command to enable/configure is enable stpd STP-Ps-Voice auto-bind
Userlevel 4
Sorry I see it now. Let me run through this configuration real fast.
Userlevel 4
Martin,

I see the issue here. Your default encapsulation mode is dot1d. The ports are added to the vlan as tagged. Dot1d bpdu's will be sent untagged so you need to change the default encapsulation mode to either emistp or pvst-plus. This also requires a carrier vlan so you will need to run the below command:

configure stpd tag < # of ps-voice>

You can also add these ports as untagged in the vlan and use the default encapsulation of dot1d.

Let me know how it goes and if you run into any issues show me where you are stuck!

Cheers!
Userlevel 5
Hi Joe,

Thanks for the info, you where correct. Here is what I had to do:

configure stpd "STP-PS-Voice" tag 202

configure stpd "STP-PS-Voice" default-encapsulation pvst-plus

configure vlan "PS-Voice" delete ports 1
configure vlan "PS-Voice" add ports 1 tagged

Switch1 # show stpd "STP-PS-Voice" ports
Port Mode State Cost Flags Priority Port ID Designated Bridge
1 PVST+ DISABLED 20000 e?pp-w---- 128 8001 00:00:00:00:00:00:00:00
48* PVST+ FORWARDING 18000 eRppaw---- 128 8030 10:00:00:04:96:35:0e:6a

Many thanks for your support.

Reply