Header Only - DO NOT REMOVE - Extreme Networks
Question

strange BGP issue (all routes unfeasable)

  • 7 January 2014
  • 0 replies
  • 812 views

Userlevel 4
Create Date: Nov 7 2013 7:22PM

One of our routers decided that all BGP routes were unfeasible. After carefully inspecting the configuration, and checking that the gateways were reachable and that ipforwarding was enabled, and that the policies were correct I was stumped.

I tried clear fdb, but this had no effect (which has occasionally fixed weird issues in the past).
I also tried disabling and re-enabling BGP, which also had no effect, once all the routes were reloaded, they were still unfeasible.
Finally restarting the BGP process fixed it.

I'm not even sure how to report this to the TAC as I don't know what caused it, or how to reproduce it, and restarting the process presumably wiped out all relevant evidence. Also, I'm more interested in why this happened in the first place (and more importantly not having it happen again) as opposed to fixing this particular occurrence, which I've already done.

So I post this note, for what its worth.

BEFORE:

Current State: OPERATIONAL
Image Selected: secondary
Image Booted: secondary
Primary ver: 15.1.2.12
Secondary ver: 15.3.2.11
patch1-2

BGP Route Statistics
Total Rxed Routes : 2032
Feasible Routes : 0
Active Routes : 0
Rejected Routes : 0
Unfeasible Routes : 2032


AFTER:

rtr.nrdg.82 # restar process "bgp"
Step 1: terminating process bgp gracefully ...
Step 2: starting process bgp ...
Restarted process bgp successfully

BGP Route Statistics
Total Rxed Routes : 2032
Feasible Routes : 2032
Active Routes : 2029
Rejected Routes : 0
Unfeasible Routes : 0



(from xxiii)

0 replies

Be the first to reply!

Reply