Suddenly can't ping anything in Virtualbox?

Userlevel 1
At first, everything was going as expected as I built my test-network in Virtualbox. Suddenly pings does not go through. I can't even ping virtualbox gateway which is directly connected to the switch (it says "destination unreachable"). Both switches are in "link11" in virtualbox and there is no overlapping links (aka loops). I have tried:

- administrative access to all files and folders including virtualbox
- disabled firewall
- reboot (obviously)
- reinstalled different revision of virtualbox (4.3.26 -> 4.0.28) including extension packs
- starting with fresh configs

..but nothing. I have not yet tried to uninstall everything and start all over from 100% clean table. It will be my next step.

Here is a screenshot of configs and ping-issue. Ports are enabled and running. I even enabled loopback for both of the switches.

Even when I type "show edp ports all" it can even see the other switch connected. I can also telnet to both in mgmt vlan (not included in these configs). This just blows my mind, I am totally lost of what's happening.

9 replies

Userlevel 6
Hello Petteri

in what you posted you are showing two different VLANs on two different switches. How are you connecting them? you need to route from one subnet to another so either there is a third subnet that these two route to or one of these VLANs reside on both switches.

Also you should use the VR statement in the Ping. Ping vr vr-d [i] it will help you in the future when you have IP addresses on multiple VRs.

Let me know if that helps

Userlevel 1
Hi Paul

Thanks for the quick reply.

You are actually right. I have been too much into routers so I have totally forgot that in order for VLAN's to ping each other they have to have same tag and under same subnet. I did and now the ping works.

So if I add OSPF in vr-default to this equation the VLAN's should be able to ping each other no matter what vlan they are in?

- Petteri
Userlevel 6
yes as long as the vlans are added correctly to the OSPF area. For example Subnet>sw1 OSPF area SN> sw2 OSPF area SN> subnet

If the neighbors are set between the two switches using OSPF area and the edge subnets and are added to OSPF as passive interfaces then the two switches will send updates and everything should talk.

Userlevel 1
Ok, seems legit. I have followed the documentation on this (which are great) and added ospf to backbone area, and when I do "sh ospf area" it says the state is DOWN. In cisco I would simply add neighbor and network and they would form adjacencies, but what should I do in this EXOS to have them up and running? Can't find anything else than "enable ospf".

Thanks a lot for your help so far!

- Petteri
Userlevel 6
hello Petteri

Yes there is an enable OSPF. the steps are

config VLAN with IP address
enable ipforwarding
config OSPF add area link type
enable OSPF

see if that gets you to a state to get a neighbor relationship

Userlevel 1
Ok I forgot that "add" before vlan. Now I got it up and running!
Ping works from another end to another!

A HUUUGE thanks to you Paul! Now my 4 days of stress is over and I can get back to work! 🙂

- Petteri
Userlevel 6
Great to hear Petteri. Glad we got it working. Thanks for posting to The Hub and let us know if there is anything else we can do to help

Userlevel 6

Just to make sure you don't suffer a known issue with VirtualBox, ALWAYS use PCnet-FAST III as Adapter Type.

Do not select any of the Intel adapters, as these strip the VLAN tags from traffic because they want to handle these themselves. This means that if you add a port as tagged to 3 vlans all you will see is untagged packets and nothing will work.
Userlevel 1
Hi Daniel

Yes, I actually bumped into your suggestion in some other topic about that and had made sure that I only use PCnet-FAST III adapter for switches. Hosts are windows 7 and they of course use some Intel PRO/1000 MT Desktop, which doesn't matter.