Summit X670V-48t - Switchport stuck in ready status


Product Model: Summit X670V-48t-FB-AC
Software Version: 16.1.3.6

Ethernet Switchport 1:7 remain in ready status even if a device is connected on it. I tried many different cables and devices but the Switchport doesn’t come Active but everything works correctly in all other Switchports. I also tried to reboot the switch without any results. I think that Switchport is broken. My question: how can I verify that Switchport is broken? Is there a way to understand with some "show" commands that there is a physical issue on that Switchport?

Thank you in advance to all the Community

Best Regards
Claudio

11 replies

Userlevel 3
Hi Claudio,

There is no explicit command as such to inform if the port has failed or not. From your information, it indeed looks like a port failure. Additionally the port LED can can notify the status with the LED lighting up or not when connecting device to the suspected port.
Userlevel 3
Hi Claudio,

check your switch config, maybe you have disable auto-negotiation on that port ?

What you see after:
sh ports 1:7 information detail | inc "Admin state"

Please see also:
https://gtacknowledge.extremenetworks.com/articles/How_To/How-To-Hard-Code-a-Port-s-Speed-and-Duplex...

--
Jarek
Userlevel 3
Hi Claudio,

If after verifying the port settings as suggested by Jarek, and testing with both auto-negotiation on or hard coding the port settings, the issue continues to persist, please run extended diagnostics during a scheduled maintenance window (if possible). Use the command: "run diagnostics extended". Please note that this command will reboot the switch to perform the hardware diagnostics tests. Once the test is completed and the switch is rebooted, you can use the "show diagnostics" command to check on the result of the diagnostics.
Please let us know if you have any questions.
Thank you.

Best regards,
Andrew
Also, you might have to run an extended diag. To do that; run the command "run diagnostic extended". Please note that the switch will become in active and will eventually reboot in about five minutes. Then run show diag to see the result.
I found on port 1:7 configuration ("Show conf detail | include 1:7):
configure ports 1:7 auto on speed 10G duplex full

I have just execute the command:
configure ports 1:7 auto on

And that Switchport starts to work, I don't know if it is a bug or just a configuration matter.

Thank you to everybody for the hints.

Regards
Claudio
Userlevel 4
Claudio wrote:

I found on port 1:7 configuration ("Show conf detail | include 1:7):
configure ports 1:7 auto on speed 10G duplex full

I have just execute the command:
configure ports 1:7 auto on

And that Switchport starts to work, I don't know if it is a bug or just a configuration matter.

Thank you to everybody for the hints.

Regards
Claudio

for that to work, the same speed settings must be set at the other side of switchport
I supose, the other side cannot support 10G speed, right?
Claudio wrote:

I found on port 1:7 configuration ("Show conf detail | include 1:7):
configure ports 1:7 auto on speed 10G duplex full

I have just execute the command:
configure ports 1:7 auto on

And that Switchport starts to work, I don't know if it is a bug or just a configuration matter.

Thank you to everybody for the hints.

Regards
Claudio

One side it was configured as "configure ports 1:7 auto on speed 10G duplex full" and the other side "configure ports 1:x auto on"
Userlevel 4
Claudio wrote:

I found on port 1:7 configuration ("Show conf detail | include 1:7):
configure ports 1:7 auto on speed 10G duplex full

I have just execute the command:
configure ports 1:7 auto on

And that Switchport starts to work, I don't know if it is a bug or just a configuration matter.

Thank you to everybody for the hints.

Regards
Claudio

as i mentioned before, both sides have to be configured in the same way
if one of the sides is not auto, then the other have to be auto off too
Userlevel 6
All ten gig links should be set to auto off speed 10 gigs.. There is no auto negotiation for ten gig links. This has been an ongoing confusion when using sfp+ ports that support 1 gig or ten gig. Other thing would be to do a show port transceiver info detail and insure the switch is seeing the optics correctly and there are no problems at the optical level.
EtherMAN wrote:

All ten gig links should be set to auto off speed 10 gigs.. There is no auto negotiation for ten gig links. This has been an ongoing confusion when using sfp+ ports that support 1 gig or ten gig. Other thing would be to do a show port transceiver info detail and insure the switch is seeing the optics correctly and there are no problems at the optical level.

In this case SFP+ ports are not involved. The port that I'm speaking about is a 10GBASE-T.
Userlevel 6
EtherMAN wrote:

All ten gig links should be set to auto off speed 10 gigs.. There is no auto negotiation for ten gig links. This has been an ongoing confusion when using sfp+ ports that support 1 gig or ten gig. Other thing would be to do a show port transceiver info detail and insure the switch is seeing the optics correctly and there are no problems at the optical level.

Ok I understand better now but there is no half-duplex for 10 gig that is why there really is no auto negotiation . One thing we have found on ten gig TX ports is that the cables should be cat 6a with the high quality connectors... If you use cat 5 or plain cat 6 it will be hit and miss on getting a ggod connection. We had so much trouble connecting our VM's to a 670G2 stack that we ended up paying the extra for sfp+ nic cards and used the Extreme DAC cables in 3 meter or 10 meter lengths... Zero issues ...

Reply