Header Only - DO NOT REMOVE - Extreme Networks

upgrade XOS from 15.1.4.3 to 16.1.3


Dears,
we have in our network BD-8810 with the release 15.1.4.3 and we would like to upgrade it to 16.1.3. can we do a direct upgrade or is there another recommended way of doing it?

Thanks
Sal

11 replies

Upgraded from 12.6.2.10 to 16.1.3.6 without any issues...not on a BD though but X480 and it worked like a charm 😉
mael wrote:

Upgraded from 12.6.2.10 to 16.1.3.6 without any issues...not on a BD though but X480 and it worked like a charm 😉

mael, could you share a summitX480 16.1.3 xos firmware and ssh xmod with me please? 🙂 I'll be pleasure to you!

Thanks.
Userlevel 7
mael wrote:

Upgraded from 12.6.2.10 to 16.1.3.6 without any issues...not on a BD though but X480 and it worked like a charm 😉

Eugene, please see this article for information on how to download and install EXOS
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Obtain-and-Upgrade-EXOS/
If you need SSH, this article will help: https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-obtain-and-install-ssh-module/
mael wrote:

Upgraded from 12.6.2.10 to 16.1.3.6 without any issues...not on a BD though but X480 and it worked like a charm 😉

Yes, but there is no summitX480 image. As i know summitX480 is a smallest image than summitX.
Userlevel 7
mael wrote:

Upgraded from 12.6.2.10 to 16.1.3.6 without any issues...not on a BD though but X480 and it worked like a charm 😉

summitX480-16.1.3.6.xos is available on eSupport, but may not be visible to you based on the support entitlement (tied to serial number) of your X480.
Userlevel 7
Hi Saleh,

You should be able to upgrade directly. However, please make sure that the MSMs and I/O modules in the chassis support 16.1. You can find this in the EXOS Hardware/Software Compatibility Guide.

-Brandon
Thanks Mael and Brandon.

Brandon

see output below
-> show version detail

Chassis : 800392-00-04 13xxx-00xxx Rev 4.0
Slot-1 : 800224-00-06 13xxx-00xxx Rev 6.0 BootROM: 1.0.4.1 IMG: 15.1.4.3
Slot-2 : 800224-00-06 13xxx-00xxx Rev 6.0 BootROM: 1.0.4.1 IMG: 15.1.4.3
Slot-3 : 800224-00-06 13xxx-00xxx Rev 6.0 BootROM: 1.0.4.1 IMG: 15.1.4.3
Slot-4 : 800228-00-06 13xxx-00xxx Rev 6.0 BootROM: 1.0.4.1 IMG: 15.1.4.3
Slot-5 :
Slot-6 :
Slot-7 :
Slot-8 :
Slot-9 :
Slot-10 :
MSM-A : 800369-00-04 12xxx-00xxx Rev 4.0 BootROM: 1.0.4.5 IMG: 15.1.4.3
MSM-B : 800369-00-04 12xxx-00xxx Rev 4.0 BootROM: 1.0.4.5 IMG: 15.1.4.3

Service First Recorded
Field Replaceable Units Days Start Date
---------------------------------------------------------------
Chassis : BD-8810 14 Apr-12-2031
Slot-1 : G48Tc 14 May-15-2013
Slot-2 : G48Tc 14 May-15-2013
Slot-3 : G48Tc 14 May-15-2013
Slot-4 : 10G4Xc 14 Mar-19-2013
Slot-5 :
Slot-6 :
Slot-7 :
Slot-8 :
Slot-9 :
Slot-10 :
MSM-A : 8900-MSM128 14 Dec-26-2012
MSM-B : 8900-MSM128 14 Dec-26-2012

from the link you provided. it should be OK to go directly to 16.1.3?

Thanks
Sal
Userlevel 6
Hi Saleh,

As Brandon mentioned the guide he linked is the best place to look for future inquiries on software compatibility with our hardware.

I took a quick look and 16.1 should run just fine on the hardware you have installed.
Userlevel 6
Hi Saleh,

All "c" cards and MSM128 that appears in your output are compatible to 16.1.3 EXOS version.

You can jump directly from 15.1 to 16.1.3.

I would recommend you to follow the procedure described in EXOS 16.1 User Guide chapter Software Upgrade and Boot Options.

You can download the EXOS 16.1 User Guide using the link below:

http://documentation.extremenetworks.com/exos/downloads/EXOS_User_Guide_16_1.pdf

Also you can find the procedure to Upgrade EXOS in the article below:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Obtain-and-Upgrade-EXOS
Userlevel 7
Another note on this, if you need to downgrade at some point: https://gtacknowledge.extremenetworks.com/articles/Solution/Cannot-log-into-EXOS-switch-after-downgr...
thanks everyone for you support.

Reply