Header Only - DO NOT REMOVE - Extreme Networks

Veiw Dropped Packets


Userlevel 5
Have seen this before in a similar setup, but have another situation where on 'show ports congestion' I am seeing packet drops.

  • rx and tx flow control has been disabled on all ports.
  • Each ports is configured for Data and Voice, with PC's hanging off phones.
  • The port utilisation is negligible.
  • Mirco bursts not suspected
  • QoS configured for voice using only QP3 & QP6 via IPTOS examination (QosMonitor is showing it working ok)
So there seems to be no reason for packets to be dropped, but there are some clearly being dropped.

So my question is if there is via EMS a means to see what packets are being dropped, perhaps that might give me a clue as to the problem.

If you have any other ideas that would be great.

Many thanks in advance.

6 replies

Userlevel 6
You can check the port congestion per qos-profile with the below command. It will let you know if it's your QP3 or QP6 traffic that is dropping. I think it's probably your QP1.

show ports qosmonitor congestion
Userlevel 5
Thanks for posting, as was a useful command.

As expected though the drops are happening in QP1.

Would still be useful to see exactly what packets are being dropped?

Many thanks
Userlevel 5
We have a great article in our knowledge base on avoiding packet loss and different tweaks you can do on the switch in order to try and mitigate it.

https://gtacknowledge.extremenetworks.com/articles/Solution/Prevent-packet-drops
Userlevel 5
Hi Brad,

Thanks for replying.

Have seen this and followed the recommendation and set the buffer size to 100%, but still seeing packet drops.

The packet drops are not continuous, and they don't increment very much, particularly often. I proposed that it isn't a micro burst, but I have no evidence for that, so it could be and it might even seem characteristic.

So the only way to see if its a micro burst is to do a packet capture and look at the I/O graph. There are some instructions here:

https://gtacknowledge.extremenetworks.com/articles/Solution/There-is-only-60-usage-on-the-port-and-p...

http://notalwaysthenetwork.com/2014/01/06/microburst-detection-with-wireshark/

So I'm going to try this and report back.

The EXOS ems system is so good, I'm still surprised there is no way to view dropped packets?

Many thanks
Userlevel 6
Hi Martin,

In addition can you check if there are any Rx errors seen in any of the ports?

"show ports rxerrors no-refresh"
Userlevel 5
Hi Karthik,

Thanks for posting.

Had looked at this previously but there are no rx or tx errors at all.

The changes I have made though, with fine tuning QoS, clearing unneeded QoS Profiles, upping buffers etc does seem to have made a difference.

There are not so many offending ports now, maybe about 8 randomly across switch. There seems to be no difference from a switch perspective then any other port in that it has a phone and PC attached to the same port.

Not physically been to site yet to trace anything - might be revelling?

It might also be that I just haven't given the cleared counters enough time to accumulate - either way, still be nice to see what's being dropped as the answer may then become obvious.

Aside from EMS logging, are there any 'debug' commands that might help?

Many thanks.

Reply