Question

VMAN+Double+tag feature


I'd like to have x150 (XOS version 15.3.2.11) double tagging untagged frame, i.e. one port accepting VLAN untagged frames and the other either Ctag and Stag frames. I found in the XOS 15.3 User Guide that Double Tagging is supported with VMAN by the following command:
configure vman vman-name add ports [ all | port_list ] {untagged {port-cvidport_cvid} | tagged}, where the parameter port-cvid is described as follows:
"Port's CVID used for untagged packets. If unspecified, untagged packetswill be single tagged with the VMAN's SVID. If specified, untagged packets will be double tagged with the VMAN's VID and the port's CVID."
Unfortunately, while trying to configure the untagged port, the command doesn't allow me to specify also the port cvid parameter.
Example: configure vman name add ports 1 untagged... and stop: now way to add port cvid parameter.
Can anyone help me in understanding where I'm wrong?

12 replies

Userlevel 4
could you please paste your configuration here
Userlevel 4
enable jumbo frames
create vman vman_tunnel_1
configure vman vman_tunnel_1 tag 100
configure vman vman_tunnel_1 add port 1 untagged---this command doesnt work for you?
configure vman vman_tunnel_1 add port 2 tagged
Hi.
The configuration you proposed is the same as mine, unless for the first command (enable jumbo frame).
About the fourth command:
configure vman vman_tunnel_1 add port 1 untagged
yes, this work fine for me. The point is that I would have wanted having the following command to work as well:
configure vman vman_tunnel_1 add port 1 untagged port-cvid port_cvid,
in order to put the c-tag in ingress with cvlan id=port_cvid, or at least this is what I thought by reading the user guide of XOS.
The result should have been like the egress frame at the port 2 double tagged, while the ingress frame at the port 1 just unframed.
Userlevel 7
Are you positive to be at least in EXOS 15.3.2? The feature was introduced with this release..
The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2
Userlevel 6
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

just curious you did add a tag id to your vman right???

command works on our 150 like this below and I believe that will add the vman to port 3 untagged with a cvid filter set up for only those cvid... I am pretty sure you have to have a tag set up on the vman though...

con vman test port 3 add cvid 123-125
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

Hi.
Yes, I add the vman stag properly. What is missing is the ctag.
However, let me refocus you on the command above in the thread, which I rewrite for your convenience:
"configure vman vman_tunnel_1 add port 1 untagged port-cvid port_cvid".
Is this command supported or not in 15.3.2, as stated in the EXOS user guide?
If yes, pls., could you show me it working in your environment? Thanks.
Userlevel 6
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

Pierluigi,

Please pay attention to the syntax. Usually, if a name is unique, you shouldn't need to indicate if it is a vlan, vman, etc...

For some reason this does not work correctly with vmans (feature, bug?).

The command
configure vman_tunnel_1 add port 1 untagged port-cvid [/code]produces the following error message

configure vman_tunnel_1 add port 2 untagged port-cvid 10
^
%% Invalid input detected at '^' marker.[/code]
while
configure vman vman_tunnel_1 add port 1 untagged port-cvid [/code]does not...

I don't have a X150 but the command worked ok in a X460...
Userlevel 6
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

Yea and my 150's are all 12.6 and below .... so not sure if command changed that much on 15.xx I know what I pasted in works on one of our 150 running 12.6
Userlevel 6
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

From the Command Reference...

configure vman vman-name add ports [ all | port_list ] {untagged {port-cvid port_cvid} | tagged}[/code]
History
This command was first available in ExtremeXOS 11.0.
The cvid keyword was added in ExtremeXOS 15.3.2.
pierluigi tramonte wrote:

The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

I can confirm to everybody that the syntax is correct. Assuming "prova" to be the name of my vman, then the output of the autocomplete command, "?", after the keyword "untagged" is , i.e. no port-cvid is expected:

* X150-001.1 # configure vman prova add port 1 untagged ?
Execute the command

So, we can finally conclude that the "port-cvid" parameter of the command:
configure vman vman-name add ports [ all | port_list ] {untagged {port-cvid port_cvid} | tagged}, as described in the user guide is not supported by 15.3.2 on x150.
Unfortunately, we don't have x460 or older OS versions.
Thanks to all.
The command: show version, gives the following answer on our equipment:
ExtremeXOS version 15.3.2.11 v1532b11-patch1-2

Reply