Header Only - DO NOT REMOVE - Extreme Networks

VPLS traffic fails after deleting vlan from sharing


Userlevel 4
Create Date: Jun 24 2013 11:21AM

Hi, I have test network: cisco switch x670 ~ mpls ~ x670 - - cisco switch And after deleting vpls service vlan from sharing port all vpls(which uses vlans from same sharing port) traffic fails. Traffic goes up after returning vlan to sharing port. Is anyone know why this happens? [/code]
(from Ogion)

3 replies

Hi
I have the same problem.
But in my case I have 2 summit x460-24t switches with ExtremeXOS version 15.2.2.7 image with MPLS enabled.

Removed the TAG vlan "pppoe_fttx" of TRUNK ports and added the vlan "pppoe_fttx" to the VPLS.
When I do the same process with any other vlan the network of vlan "pppoe_fttx" work stop.
But the command: show vpls detail return status UP

This is my how to configurations:

### OSPF
SW-CORE# create vlan loopback
SW-CORE# enable loopback-mode vlan loopback
SW-CORE# configure vlan loopback ipaddress 10.255.255.254/32
SW-CORE# enable ipforwarding vlan loopback
SW-CORE# configure ospf routerid 10.255.255.254
SW-CORE# configure ospf add vlan "loopback" area 0.0.0.0 link-type broadcast passive
SW-CORE# enable ipforwarding vlan SwCoreDC_SwHubDc
SW-CORE# configure ospf add vlan SwCoreDC_SwHubDc area 0.0.0.0 link-type point-to-point
SW-CORE# enable ospf

SW-HUB_DC# create vlan loopback
SW-HUB_DC# enable loopback-mode vlan loopback
SW-HUB_DC# configure vlan loopback ipaddress 10.255.255.253/32
SW-HUB_DC# enable ipforwarding vlan loopback
SW-HUB_DC# configure ospf routerid 10.255.255.253
SW-HUB_DC# configure ospf add vlan "loopback" area 0.0.0.0 link-type broadcast passive
SW-HUB_DC# enable ipforwarding vlan Sw01_HUBDC-SwCore_DC
SW-HUB_DC# configure ospf add vlan Sw01_HUBDC-SwCore_DC area 0.0.0.0 link-type point-to-point
SW-HUB_DC# enable ospf

### MPLS
SW-CORE# configure mpls add vlan "loopback"
SW-CORE# enable mpls vlan "loopback"
SW-CORE# enable mpls ldp vlan "loopback"
SW-CORE# configure mpls add vlan "SwCoreDC_SwHubDc"
SW-CORE# enable mpls vlan "SwCoreDC_SwHubDc"
SW-CORE# enable mpls ldp vlan "SwCoreDC_SwHubDc"
SW-CORE# configure mpls lsr-id 10.255.255.254
SW-CORE# enable mpls protocol ldp
SW-CORE# enable jumbo-frame ports all
SW-CORE# enable mpls

SW-HUB_DC# configure mpls add vlan "loopback"
SW-HUB_DC# enable mpls vlan "loopback"
SW-HUB_DC# enable mpls ldp vlan "loopback"
SW-HUB_DC# configure mpls add vlan "Sw01_HUBDC-SwCore_DC"
SW-HUB_DC# enable mpls vlan "Sw01_HUBDC-SwCore_DC"
SW-HUB_DC# enable mpls ldp vlan "Sw01_HUBDC-SwCore_DC"
SW-HUB_DC# configure mpls lsr-id 10.255.255.253
SW-HUB_DC# enable mpls protocol ldp
SW-HUB_DC# enable jumbo-frame ports all
SW-HUB_DC# enable mpls

### VPLS
SW-CORE# configure vlan pppoe_fttx delete ports 1:24
SW-CORE# disable igmp snooping vlan pppoe_fttx
SW-CORE# create vpls vpls_pppoefttx fec-id-type pseudo-wire 50
SW-CORE# configure vpls vpls_pppoefttx add peer 10.255.255.253
SW-CORE# configure vpls vpls_pppoefttx add service vlan pppoe_fttx

SW-HUB_DC# configure vlan pppoe_fttx delete ports 27
SW-HUB_DC# disable igmp snooping vlan pppoe_fttx
SW-HUB_DC# create vpls vpls_pppoefttx fec-id-type pseudo-wire 50
SW-HUB_DC# configure vpls vpls_pppoefttx add peer 10.255.255.254
SW-HUB_DC# configure vpls vpls_pppoefttx add service vlan pppoe_fttx
Based on my understanding, VPLS traffic failing - when we removed vpls service vlans from sharing port - i hope this sharing port is the only port where this vlans are added. If that is so,

VPLS service vlans will not be active untill it has an active port on it. As VPLS service vlans not yet active - VPLS tunnel using this service vlan's never shows UP.
I solved my problem making the upgrade image for Exos 15.3.1.4 patch1-30.

Reply