Question

Weird Routing loop


Hi,

We have a weird routing loop that I cannot explain. I believe it's a software bug, but just want to be sure.

I have 2 routers A and B (Extreme X480) connected together in the same AS and exchanging full routing table without any filter.

Router A got one transit link announcing full Internet routing table. Router A is sending his local prefix only (one /22) to that transit provider.
Router B got another transit link announcing full Internet routing table. Router B is sending his local prefix only (one /22) to that transit provider.

Simple multihomed topology.

I am having issue with 1 IP of one /20 Internet prefix.
This /20 is prefered on Router B, because AS-PATH is shorter.

From Router B, I can traceroute, ping and everything to the whole /20, no matter the source.

From Router A, I can traceroute, ping for the whole /20 via Router B, EXCEPT for one IP of that /20. That IP is looping between Router A and Router B.

I searched for policy, filter, static route or something that could explain why Router B is sending back the traffic to Router A only for this specific destination .. but nothing. The BGP table and routing table yet say to route that destination to the transit provider on Router B.

In other word, have you ever seen a router send traffic to a destination that is not indicated in the routing / BGP table ?

Thanks for anwsers / ideas

Greg

5 replies

Userlevel 2
Hi,

you are positive that you don't have a preferred route (more precise or from another protocol) for that IP/Subnet on Router B that would explain this?
Hello,

I am positive, no preferred route (more precise or from another protocol for that IP subnet) on router B.

I did another test : I forced a static route for that specific /32 to go out via the Transit provider. Same result : From Router A flow is going to Router B and go back to Router A.

I tried to source from another interface of router B : same result. So the problem is not on Router A, it's on router B.

I check with the transit provider of router B, his routing table for /20 is crystal clear. He is only announcing the /20 (nothing shorter)
Userlevel 2
I realized you said it works fine from Router B, so you're right, you should not have a specific /32 on router B forcing that traffic back to Router A, or even from Router B you'd have the issue.

What release are you using? Is IP Route Compression enabled?

That IP is looping directly between A and B, right?
Re,

Using 12.6.3.2 on both router A and B.
Route compression is not enabled.

That IP is looping between A and B yes. I did the test when sourcing the test from Router A, but also from any Device connected to Router B : the loop always goes between A and B.
Userlevel 2
open a case, it needs investigation.

Reply