Header Only - DO NOT REMOVE - Extreme Networks
Question

X440-G2-24p Fan Speeds


What is the go with the X440-G2 fan speeds. We have some of these switches in class rooms and cabinets in classrooms and they are so noisy. We also have some in one of our data centers and its at a much much lower temp, but the same fan speed?

Office Switch:
Events 2.14 # sh temp
Field Replaceable Units Temp (C) Status Min Normal Max
--------------------------------------------------------------------------------
Switch : X440G2-24p-10G4 90.20 Normal 0 10-100 110
Events 2.15 # sh fan

Slot-1 FanTray information:
State: Operational
NumFan: 4
Fan-1: Operational at 7440 RPM
Fan-2: Operational at 7560 RPM
Fan-3: Operational at 7620 RPM
Fan-4: Operational at 7680 RPM

Data Center Switch:
Server Room Edge.1 # sh temp
Field Replaceable Units Temp (C) Status Min Normal Max
---------------------------------------------------------------------------
Switch : X440G2-48p-10G4 52.50 Normal 0 10-100 110
Server Room Edge.2 # sh fan

FanTray information:
State: Operational
NumFan: 4
Fan-1: Operational at 7680 RPM
Fan-2: Operational at 7680 RPM
Fan-3: Operational at 7620 RPM
Fan-4: Operational at 7620 RPM
Server Room Edge.3 #

They're about 40 degrees apart but running the same fan speeds? I have read that <30 and they run half speed? Do they not ramp up on scale with the temperature?

5 replies

Userlevel 3
I had a ticket open at GTAC about the same issue.
Their response was that the temparature/fan level is normal

In debug mode you can see this:
(debug) TST2-X440G2-5.14 # debug hal show platform platformInfo

PlatformName: X440G2-24p-10G4
PlatformId: 138 Type: 1
HAL_SELF_SLOT: 1
HAL_AM_I_PRIMARY: 1
HAL_GET_NUM_MAC_ADDR: 1
MAC[0]: 00 04 96 9e 89 67
HAL_GET_NUM_IO_SLOT: 1
HAL_GET_NUM_FM_SLOT: 0
HAL_GET_NUM_SWFB_SLOT: 0
HAL_GET_NUM_IO_SWFB_SLOT: 1
HAL_GET_NUM_MSM_SLOT: 0
HAL_GET_NUM_TOTAL_SLOT: 1

HAL_FIRST_SW_CAP_SLOT: 1
HAL_LAST_SW_CAP_SLOT: 1

HAL_GET_NUM_FAN_SLOT: 1
HAL_GET_NUM_PS_SLOT: 2

=======Environmental Data========
Fan Slot: 1 State OPERATIONAL

Fan Part Info:
Name:
SerialNum:
PartNum:
Revision: 0.0
Flags: 1
FailureCode: 0
PowerOnDate: Mon Apr 30 12:59:04 2018

Fimware Rev: BuildTag:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 5.00W
Fan#0: State: OPERATIONAL Location:
Fan#1: State: OPERATIONAL Location:
Fan#2: State: OPERATIONAL Location:
Fan#3: State: OPERATIONAL Location:
Odometer: not supported
Temperature: 0 Celsius
RpmLow 500 RpmHigh 22000
Fan1: 4440 rpm
Failed 0 FailedCount 0
Fan2: 4560 rpm
Failed 0 FailedCount 0
Fan3: 4140 rpm
Failed 0 FailedCount 0
Fan4: 4200 rpm
Failed 0 FailedCount 0
Fan control period: 5000 msec
Desired temperature: 30
Fan Power Level: 100 errorSum: 210000000

Power Supply Slot: 1 State: POWER_ON

Power Supply Part Info:
Name: Internal Power Supply
SerialNum:
PartNum:
Revision: 0.0
Flags: 1
FailureCode: 0
PowerOnDate: Thu Jan 1 01:00:00 1970

Fimware Rev: 1.1 BuildTag: Turbine on 10/1/2004
Nominal line voltage: 120 V
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 200.00W

Redundant Power Info:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 190.00W

Redundant N+N Power Info:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 190.00W
Odometer: not supported
Temperature: not supported
(Range 0 - 0)
Fan Speeds: (Range 0 - 0)
InputVoltage: 0 V Current: 0 A
OutputVoltage: 0 V Current: 0 A
Eff : 89

Chassis Odometer: 24787800 sec

Num Card Type Supported: 2
CardTypeName:
X440G2-24p-10G4
__UNSUPPORTED__
Reading phy version information for slot 1 gunit 0
Phy version : 0x00000000 (starting at port 25)
(debug) TST2-X440G2-5.15 #

the fan could go as low as 500rpm, but i never seen it like this!
the temparature shown is an addition of ambient + cpu
Seems silly that the only settings for these fans seem to be Off, Noisy or Screaming...
Userlevel 6
The X440G2 does not have "setting" for the speed = you can not set the speed.
The X440G2 does have linear fan speed = there is 255 speed levels. It should not be "off, noisy, screaming".

There were bugs in the firmware regarding the fan speed control = I suggest to check your firmware.

The fan speed depends on the PoE consumption and ambient temperature.
Userlevel 3
dear pala,
i am on newest version
TST2-X440G2-5.6 # show version
Switch : 800616-00-09 1723N-42176 Rev 09 BootROM: 1.0.1.8 IMG: 22.5.1.7
PSU-1 : Internal Power Supply
PSU-2 :

Image : ExtremeXOS version 22.5.1.7 by release-manager
on Tue May 22 11:48:55 EDT 2018
BootROM : 1.0.1.8
Diagnostics : 5.12
Certified Version : EXOS Linux 3.18.48, FIPS fips-ecp-2.0.16

TST2-X440G2-5.7 #

And I have only 2 poe devices connected

TST2-X440G2-5.5 # show inline-power stats ports 1-24

STATISTICS COUNTERS
Port State Class Absent InvSig Denied OverCurrent Short
1 searching ------ 0 46 0 0 0
2 searching ------ 0 193 0 0 0
3 searching ------ 0 46 0 0 0
4 searching ------ 0 46 0 0 0
5 searching ------ 0 49 0 0 0
6 searching ------ 0 49 0 0 0
7 searching ------ 0 57 0 0 0
8 searching ------ 0 48 0 0 0
9 searching ------ 0 18 0 0 0
10 searching ------ 0 15 0 0 0
11 searching ------ 0 13 0 0 0
12 searching ------ 0 180 0 0 0
13 searching ------ 0 218 0 0 0
14 delivering class3 0 0 0 0 0
15 searching ------ 0 151 0 0 0
16 delivering class3 0 0 0 0 0
17 searching ------ 0 27 0 0 0
18 searching ------ 0 136 0 0 0
19 searching ------ 0 242 0 0 0
20 searching ------ 0 189 0 0 0
21 searching ------ 0 237 0 0 0
22 searching ------ 0 242 0 0 0
23 searching ------ 0 101 0 0 0
24 searching ------ 0 68 0 0 0

the fans are always above a normal level:
TST2-X440G2-5.1 # show fans

Slot-1 FanTray information:
State: Operational
NumFan: 4
Fan-1: Operational at 6180 RPM
Fan-2: Operational at 6180 RPM
Fan-3: Operational at 6180 RPM
Fan-4: Operational at 6240 RPM

As the temperature is nearly maximum in a normal IT rack without ac:

(debug) TST2-X440G2-5.8 # !cat /proc/extr/temp
Sensor Module Type Driver Temp Tos Thyst
mb-default 2 1 lm75 44.50 88.00 50.00
mb-hotspot 2 3 lm75 40.00 71.00 66.00
cpu-temp-remote 2 4 tmp435 50.37
cpu-temp-local 2 5 tmp435 36.37
(debug) TST2-X440G2-5.9 # sh temp
Field Replaceable Units Temp (C) Status Min Normal Max
---------------------------------------------------------------------------
Switch : X440G2-24p-10G4 89.78 Normal 0 10-100 110

I was told the temperature value is an addition of cpu temp + ambient temp
So in my eyes it is impossible to reach a normal value af 10 degrees celsius

the x440g2 is very noisy, we installed them instead of A2 and A4 switches. these were not that loud.
I run into the same problem. With 2 connected PoE Devices the fanspeed increase up to 10.000rpm. After disabling the PoE Devices, the fanspeed went down to 2.100rpm.
In my opinion, these switches are to noisy for any office enviroments and useless with PoE.

Reply