8810, bcmRX - 40-60% CPU utilization

  • 7 January 2014
  • 3 replies

Userlevel 4
Create Date: Sep 4 2012 8:00AM


While analyzing issues we are facing i came across very high CPU utilization on one of our Blackdiamond 8810 switches. I don't have to output from top handy but bcmRX was using between 40-60% of the CPU. We tried disabling all VLANS and it still used 30-40% of the CPU and it continued to use 30-40% of CPU post reboot.

I've tried google and it came up with this link which says it could be due to very large number of packets in the network which are using up the CPU, doesn't make since because the part of the network that is connected to this switch is not functioning at the moment (which is issue I set out to fix initially).

I am new to this and am learning each day, any pointers on what could be causing this and a suitable resolution would be of great help.

Thanks in advance.

Vikram (from vikram_nair)

3 replies

Userlevel 4
Create Date: Sep 5 2012 5:08AM

VikramThat process is for the receive traffic to the CPU which is traffic that is processed by the CPU. Normally this traffic are broadcast traffic, unknown traffic and protocol specific traffic destined to the CPU. One thing to try is to enable CPU DoS protect and see if that triggers anything. If there is traffic with a pattern that is hitting the CPU the DoS protection will alert you and if possible create an ACL.I have also see issues where there is a loop in the network that is farther into the network. The traffic makes its way to the switch and the traffic is sent to CPU as needs to be forwarded slow path. The CPU DoS protect will also show that in the fact that it will alert you to traffic hitting the CPU but since it is all unique the process will not be able to create an ACL.I would also recommend opening up a case with TAC as there are additional debug commands and logs they can look at to help determine the root cause.ThanksP (from Paul_Russo)
Userlevel 4
Create Date: Sep 5 2012 9:53AM

hello P,

Thanks a lot for your reply.

The issue was (as you said) due to a loop farther into the network.

Thanks again.
Vikram (from vikram_nair)
Userlevel 4
Create Date: Sep 5 2012 10:36AM

great glad you got it worked outP (from Paul_Russo)