Exos connect Extreme Cloud IQ

  • 9 April 2020
  • 2 replies

Hi there:
I am trying to connect a switch to the IQ cloud, I have reviewed this following forum:

As reviewed, there is a separate module for connecting to the cloud but in version 30.5 it is not available. However I have seen that for version 30.6 there is such a module and I have updated the switch x460-G2




But nevertheless after uploading the module, it throws an error when activating the “iqagent” process. It shows me the following logs:


Well, and I'm detained until now. On the cloud side, I have already added the device.

I hope your prompt help.

Best regards.


2 replies

Userlevel 7

Hi Kevin,


not sure whether you’ve fixed the issue but I’ve tried it today with my X44G2 and latest software and it worked…



Userlevel 2

Hi Kevin,


I have been able to connect two switches to Cloud IQ without the xmod file (X440G2 and X465). The only thing required was the command to spawn the python deamon which is in your linked article:


create process iqagent python-module exos.apps.iqagent start auto vr VR-Default


Have you tried that command? Can you check what the output “show process iqagent” looks like on your switch?


Kind regards