Solved

Extreme Switch Telnet asks for Password First

  • 18 November 2020
  • 14 replies
  • 82 views

When i telnet to extreme switch it asks for password first.

Rather than asking for Username/Password.

Escape character is '^]'.

 

telnet session telnet0 on /dev/ptyb0

 

password:

 

 

icon

Best answer by Miguel-Angel RODRIGUEZ-GARCIA 18 November 2020, 14:12

View original

14 replies

Userlevel 6
Badge +1

press enter

 

Mig

I have some automation build around this. I want it to ask for Login: Then password. Older extremes do that.

Userlevel 6

What switch and  xos are we talking about?

System Type:      X460G2-48p-10G4

ExtremeXOS version 30.2.1.8

Userlevel 6
Badge +1

vaiku,

 

Can you post the result of : show conf detail | in telnet ?

Mig

 

show conf detail | in telnet

# Module telnetd configuration.

enable telnet

configure telnet port 23

configure telnet vr all

Userlevel 6
Badge +1

Strange,

 

Are you using a specific telnet client sending the username automatically?

If so, could you test with a command line telnet connection?

Mig

Userlevel 6
Badge +1

vaiku,

Here my output with the same settings on 30.7.1.1:

telnet session telnet0 on /dev/ptyb0


login: admin

password:

ExtremeXOS

Copyright (C) 1996-2020 Extreme Networks. All rights reserved.

This product is protected by one or more US patents listed at https://www.extremenetworks.com/company/legal/patents/ along with their foreign counterparts.

==========================================================================


Press the <tab> or '?' key at any time for completions.

Remember to save your configuration changes.

There have been 3 successful logins since last reboot and 2 failed logins since last successful login

Last Successful Login was on: Wed Nov 18 11:13:49 2020

* X435-8P-2T-W.1 #

 

Is SSH enabled on those switches?

What is the behaviour with SSH?

Did you configured radius authentication?

Mig

It's a expect script that does the login and port change.

if I telnet to the switch this is what I see.

Escape character is '^]'.

 

telnet session telnet0 on /dev/ptyb0

 

password:

enter key then it asks for sure name and password.

Userlevel 6
Badge +1

vaiku,

If you try with a telnet client what is the behaviour?

If it is not the same the issue rely on the expect layer.

 

What you coud do there is check for the input

telnet session telnet0 on /dev/ptyb0

 

password:” and if it occurs, just send a carriage return to go to the username password.

 

Could you share the login part of the script?

Mig

So when I login from a terminal 

I get 

Escape character is '^]'.

 

telnet session telnet0 on /dev/ptyb0

 

password:

 

What I want to do is when I login from the terminal it should ask for login/password 

not prompt for a password.

 

Userlevel 6
Badge +1

Vaiku,

We miss something.

What is the OS used for telnet and what is the command used?

Can you try it with SSH?

Mig

Userlevel 6
Badge +1

Vaiku,

This seems similar to your issue: https://gtacknowledge.extremenetworks.com/pkb_mobile#article/Q_A/kA234000000PH6aCAG/s

Mig

Thank you. 

This helped https://gtacknowledge.extremenetworks.com/pkb_mobile#article/Q_A/kA234000000PH6aCAG/s 

Reply