Solved

from the box X435 - stuck in reloading - cfgmgr error

  • 13 January 2021
  • 6 replies
  • 71 views

Hello, we are having 2 news switches x435 that are having a cfgmgr error and getting in a continues loop / reboot situation. This model of switches are using the bootmenu 2.0 neither ones firmwares from the box is behaving correctly, besides trying the other firmware, the others options from the bootmenu did not help. Besides We are not finding how to install a new firmware using the bootmenu 2.0 to try. So Any idea to fix this problem ?

 

starting version 237
init started: BusyBox v1.28.3 (2019-12-11 20:00:58 America)
Starting ExtremeXOS 30.5.0b259
Copyright (C) 1996-2019 Extreme Networks.  All rights reserved.
This product is protected by one or more US patents listed at https://www.extremenetworks.com/company/legal/patents/ along with their foreign counterparts.


(pending-AAA) login: 

Authentication Service (AAA) on the master node is now available for login.

rc = -14
cfgmgr: systemInfoAPI.c:3731: setSwVerWhenMovedCliCmdsHidden: Assertion `rc > WKNIO_OK' failed.
Process cfgmgr pid 1758 died with signal 6

Code:
b6afe08c  e3a03008 
b6afe090  e3a070af 
b6afe094  ef000000 
b6afe098 <e1a0000c>
b6afe09c  e28ddf41 
b6afe0a0  e8bd8090 
b6afe0a4  e59f3018 
b6afe0a8  e2601000 
b6afe0ac  ee1d2f70 

The system is going down NOW! Sent SIGTERM to all processes
Sent SIGKILL to all processes
Requesting system reboot


U-Boot 2016.01--00013-g974dd096a4 (Oct 30 2019 - 11:16:39 -0400)

icon

Best answer by rrocha 15 January 2021, 18:13

Yes, We decide to open the GTAC, they are suggesting to start a RMA procedure.  
To clarifly, as I tried to said before, this Switches x435 are brand new from the box, so they have no configurations.

We tried all options from the bootmenu 2.0, none behave differently. All of them still keep the switches giving this error and persisting in rebooting. As this Switches have default config and they are not able to start its operational system only the console cable is avaible to use to interact with them. 

Thanks for the help and kindness.

View original

6 replies

Userlevel 6
Badge +1

I did not know the exact wording, but by 

Does that mean you also tried to boot without a configuration or with XOS Rescue

 

I meant. EXOS: Rescue and EXOS: Primary

 

I don’t know a current documentation regarding the bootloader. But “Process cfgmgr pid 1758 died with signal 6” from your error message can (but does not have to) point into an configuration issue.

I assume you didn’t change the config because of the reboot loop. But you can try “EXOS: Rescue” and “EXOS: PrimarySecondary - with default configuration”.

In addition you can try with and without serial cabel/lan cable, depending on what you use to configure it. If that doesn't help, the GTAC will have to step in.

Userlevel 6
Badge +1

Hello,

You can update you switch from the boot menu. See here:

https://extremeportal.force.com/ExtrArticleDetail?an=000083340&q=Update%20boot%20%20xos%20menu

Use XOS version 30.7.1.1.patch1-86 or if 31.x is necessary 31.1.1.3.patch1-1

Yes, We decide to open the GTAC, they are suggesting to start a RMA procedure.  
To clarifly, as I tried to said before, this Switches x435 are brand new from the box, so they have no configurations.

We tried all options from the bootmenu 2.0, none behave differently. All of them still keep the switches giving this error and persisting in rebooting. As this Switches have default config and they are not able to start its operational system only the console cable is avaible to use to interact with them. 

Thanks for the help and kindness.

Hi StephanH, as I said I would like to try to do that, but the system is using the bootmenu 2.0 without this options. We are not able to find any documention about this version. So we are lost about how to upgrade.

Userlevel 6
Badge +1

You write the other options from the boot menu do not help. Does that mean you also tried to boot without a configuration or with XOS Rescue?

If yes, then the best way to solve the problem is a GTAC case.


 

I am not sure. Maybe We are not able to select or find these options that you mentioned or they did not do anything differently. We tried all of bellow options.
EXOS Boot Menu ( 2.0.0.5 ) *

EXOS: Default
EXOS: Primary -
EXOS: Secondary -
EXOS: Primary - with default configuration
EXOS: Secondary - with default configuration
EXOS: Rescue
Run Operational Diagnostics
Run Manufacturing Diagnostics
Update bootloader
Reboot system

 

Do yo have any articles showing how to operate the system using version 2.0 of bootmenu ?

Also can you clarify if in this version is possible or not to upgrade the firmware from the bootmenu ?

Reply